Networking Vista PC to XP Laptop

  HighTower 23:23 07 May 07
Locked

Now this is weird. It all used to work great but computers are like that eh!

Anyway, PC has Vista Business Edition on it, Laptop has XP Pro. Both have shared folders, both have the same user accounts and passwords, both have IP addresses in the same range, both are in the same Workgroup and both have had the firewalls disabled (whilst disconnected from the net) for testing purposes.

On the Vista machine Network Discovery is turned on, and so is File Sharing. Password Protected Sharing is turned off. I've installed the Link-Layer Topology Discovery (LLTD) update on the XP machine.

So, after all this the two computers cannot see any folders or any reference to each other anywhere at all, with the exception of the Vista machine. The Vista machine can show the XP Laptop on the Network Map (connected via dashed lines), but the Laptop doesn't appear anywhere else in the Network Neighborhood. As far as the Laptop is concerned the Vista PC doesn't even exist!

The laptop is connected wirelessly to a router, the PC connects to the same router via CAT5e. Both use the web from this router without a problem.

Have I missed something obvious?

  Scottiedogg 12:59 08 May 07

This is I believe is a Vista issue which I personally have not yet figured. I am having an identical problem on an 'identical' setup. My PC is multibooted with XP Pro, Vista and Linux and works fine with XP running. Since installing Vista though I have had exactly the same issue (Although the XP setup obviously still works fine) so I can discount a router problem. When I find a solution I will let you know but in the meantime if anyone has any suggestions, please post them!

Thanks

Scott

  HighTower 13:03 08 May 07

Thanks for your response! I was almost tearing my hair out last night thinking "What have I missed!". My trick usually is to forget to share a folder.

So perhaps this has happened because of a Vista automatic update? I'm guessing that your system has worked in the past like mine?

  nutter75 23:15 09 May 07

Been working hard to find the solution to this one as I have the same set up and could not connect my xp laptop to my vista pc on a wireless network. The problem lies in the router which sits inbetween the two pc's on the network map. Configure the routers settings and disable UPnP and hey presto the computers appear on the network!

  Abra {tag28} 01:46 10 May 07

Go to your NETWORK CENTER in Control Panel & change the Network Category to PUBLIC. You should now be able to see the XP machine from Vista.

Go to USER ACCOUNTS in Control Panel > click on Manage Your Network Passwords on the left menu -- there should be an existing entry, select the properties for that entry and add a username and change the existing password.

Restart the Vista computer.

With the username and password that you provided, you should now be able to access the Vista computer from the XP machine.

This will however bypass the inbuild network security for vista, so make sure that you have software firewalls/antivirus in place etc.

Seems to work in most cases!

  setecio 11:59 10 May 07

Bookmarked.

  HighTower 13:12 10 May 07

I'll give this a bash tonight. Thanks for your posts.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

Where HTML5 is headed next

MacBook Pro v Surface Pro 5