network: Limited or no connectivity

  Gazz2005 19:47 28 Dec 05
Locked

Well I have a home network currently consisting of two PCs connected via an ethernet switch, which share the internet and files between them, a few days ago I got the error message on the client computer that there network had "limited or no connectivity" so there may be probelms sharing the internet etc and yes it was right the internet wasnt being shared and the computer wouldnt even recognise there was another PC on the network. Im basically out of ideas with this problem, I have been all over the internet looking at this and that but nothing so far has worked, I have tried both fixes for the networking issues with SP2, which I dont consider to be the problem but I thought id try them all the same. Ive tried changing the IP address through the command menu and also "repair" function. Ive tried turning everything off waiting and turning it back on, also trying to set the network up again. Chances are Ive tried most everything you can think of (id hope not! but I fear that is the case) So im open to any suggestions, if you need anymore information let me know, help!
Both PCs are running windows XP professional and are both fairly new, P4 3ghz. Im willing to try basically anything now as the only option I will be left with is replacing the switch and to be truely honest Im not 100% sure that it is broken, so anyway to find that out would be welcomed, thanks all in advance.

  mgmcc 20:07 28 Dec 05

The problem is that your "client" PC isn't getting its IP address from the "host" PC's DHCP server. Windows is almost certainly allocating an address in the 169.254.x.x range which won't let you connect to the "host" and definitely won't allow internet access.

Make sure that "Internet Connection Sharing" is still enabled on the actual internet (modem) connection in the "host" PC and that its Local Area Connection has the fixed IP address of 192.168.0.1 and subnet mask 255.255.255.0

To enable “Internet Connection Sharing” in Windows XP, open the Network Connections folder, right click the actual internet connection (modem connection), select Properties and then the Advanced tab. Tick the box “Allow other network users...etc”.

The "client" PC's Local Area Connection should be set to get its IP address automatically, which it does (or should do!) by DHCP from the "host" PC.

  Gazz2005 20:25 28 Dec 05

Well ok that is a little wierd, mgmcc: thanks for the advice, I followed what you said but found that the "Allow other network.." was already ticked but there was an advanced button so I hit that and there were many boxes unticked, some of which had the DCHP in the description and I recognised that from my previous attempts to start the network up again so I ticked them restarted both machines and it appears to be working fine now! So Im really not sure what on earth is happening there but I suppose the problem is solved. If by any chance you have an idea what could have happened, please enlighten me!

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…