Network filesharing totally disabled Win XP ProSP1

  quaggydog 12:10 16 Apr 05
Locked

I have a laptop running Win XP Pro SP1. It was provided by my employer for working from home. It was originally configured to log on to a domain but I have tried to reconfigure it to access my 2 other PCs on my home network (Linksys WAG54G gateway, Win XP Home SP2 desktop, Win 98 SE laptop) but there seems to be some fundamental network setup missing that prevents me from successfully accessing the other 2 PCs. When I browse my home workgroup, it says access is denied. A friend's XP had no problem accessing the same workgroup. Even "shared" folders on the "problem" laptop do not show up on its "My Network Places" which leads me to think that the laptop has been configured to prevent network file sharing at a "deeper" level. The only software on the "problem" laptop that I don't recognise or understand is something called "Dameware" - but have no reason to think it is related. Anyone got any ideas?

  LastChip 19:33 16 Apr 05

It's a Management utility almost certainly loaded by your company for remote administration.

Your post poses more questions than answers.

Do you wish to use your laptop for both your company network and your own?

If you do, you would probably be better off adding a new user to the machine, leaving your present configuration for company work, and configuring the new user for your home network.

If not, (and either way anyway) you have to look at how the machine is trying to join the network.

By far the easiest method with your router, is to use the router as a DHCP server and configure your home machines to obtain a network address from the server (router). What you don't want, is more than one DHCP server, so if one of your machines are configured as such, the router should have a defined address range list, to listen out for, and should not be set as a server.

Many "Access Denied" errors are caused by Firewalls, and these should all be turned off for the duration of the troubleshooting period. Once the network is working correctly, they can be reinstated. I am not familiar with your router, but the chances are, it has its own Firewall anyway.

If you open up a Command Prompt on one of the machines using the network, and type the command;

ipconfig /all [enter]

(note the space between the g and /)

You will now see some information.

1. Is DHCP enabled?

2. IP Address (this is the machines address)

3. Subnet Mask

4. Default Gateway (this should be your routers address)

5. DHCP Server (this will reveal where DHCP is initiated - if it is active as in 1 above)

The rest is not relevant at this time.

Now do the same on your problem laptop and check that the IP address is in the same range (not an identical address) and the Subnet is the same. Are points 4 and 5 the same too?

If you can come back with some answers to these questions, maybe we can move forward towards a resolution.

  quaggydog 20:43 16 Apr 05

Thanks for the time you have taken to kick this off. OK... here goes...

Ideally, I would like to use both company network and my own. But I am now at the stage where I am less bothered about the company network - if I can sort out connectivity to my own network, I will take it back into work and see what happens. So let's just say I am only interested in my home network.

I am using the router as a DHCP server. (Range 192.168.1.1 to 49). All software firewalls disabled.

ipconfig /all [enter] for "OK" PC
1. Is DHCP enabled? Yes
2. IP Address? 192.168.1.3
3. Subnet Mask? 255.255.255.0
4. Default Gateway? 192.168.1.1 (router's address)
5. DHCP Server? 192.168.1.1

ipconfig /all [enter] for "problem" PC
1. Is DHCP enabled? Yes
2. IP Address? 192.168.1.2
3. Subnet Mask? 255.255.255.0
4. Default Gateway? 192.168.1.1 (router's address)
5. DHCP Server? 192.168.1.1

I hope this helps.
Thanks again for thinking about this.

  LastChip 21:12 16 Apr 05

(all looks good so far)

From one of the "good" machines, can you see the problem laptop in My Network Places or Network Neighborhood, or visa versa?

What I am trying to establish here, is are we dealing with a file and printer sharing problem only, or is it a fundamental problem with the machine establishing itself on the network.

Please also make absolutely sure that all computers have an individual name, but they all share the SAME Workgroup. Note; the defaults are different for XP and Win98se, so you could have chosen either default or something totally different, but whatever the choice, it must be consistent throughout the network.

  quaggydog 21:30 16 Apr 05

The 2 "good" machines can see each other (they are on a workgroup called "L1") but cannot see the "problem" machine. The "problem" machine can see "L1" (as it is it's workgroup too) but cannot see anything in the workgroup. Therefore, I think it is a more fundamental problem (although the "problem" machine can access the internet via the router - I am writing this from the "problem" PC).

Also, worth restating that shared folders on the "problem" machine are not visible in the machine's own "Network Places". This seems very strange.

All computers have unique names and have workgroup "L1".

  LastChip 21:58 16 Apr 05

Has this been installed on the machine?

To check, Right Click My Network Places; Properties; Right Click Local Area Connection; Properties; and see if you have File and Printer Sharing listed in the box.

  quaggydog 22:03 16 Apr 05

"File and Printer Sharing for Microsoft Networks" is present and ticked.

  LastChip 22:18 16 Apr 05

If you now select the Authentication Tab and assuming for you, security isn't an issue, make sure all three boxes are ticked. Now move to the Advanced Tab. Do you have a Windows Firewall "Settings" button?

  quaggydog 22:27 16 Apr 05

I don't have an "Authentication" tab. Just "General", "Wireless Networks", "Advanced". (It is a wireless connection).
Firewall "Settings" button is greyed-out unless I enable the firewall. Currently Firewall is disabled.

  LastChip 23:41 16 Apr 05

as you said you had disabled it.

The Advanced button deals with authentication, so maybe this is where your problem resides.

At the moment, all I can think of is, maybe your company IT department has disabled some authentication policies either through Dameware (which I know nothing about!) or more directly through Group Policy or even a Registry hack.

The fact that you have been unable to connect, should have generated error logs. It may be a good idea to take a look and see what is there, as it may help point you in the right direction to sort the problem out. Go to Control Panel; Administrative Tools; Event Viewer; and look at the Application and System logs. See if that helps.

You may also wish to take a look at the Group Policy settings. In particular, those related to security to see if anything has been disabled. In order to do this, go to; Start; Run; and type;

mmc [OK]

This will open up the Console and from there click; Console; Add/Remove Snap-in; Add; and from the window that opens, select Group Policy; click Add; Finish; and it is now ready to use. Open it up and take a look at the security settings.

In the meantime I'll give it some more thought, or maybe someone else will come along with some suggestions to help you.

  LastChip 00:01 17 Apr 05

should read Authentication Tab!!

I don't have XP Pro here to check, but Win2K is very similar in most respects and within Local Computer Policy; Administrative Templates; Network; Network and Dial-up Connections; there is an option to "Prohibit TCP/IP advanced configuration". I wonder if it is prohibited on yours? (it may be a slightly different path to the policy).

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…