Network File share works one way, but not the othe

  Stuarthouston 19:51 30 Jul 05
Locked

Hi all, I have a wireless network connecting 3 computers through a router to the internet, and sharing a printer through the main computer. I had file sharing set up so that each computer could see the others on the network and access files as necessary. It all worked fine, but now when i try to access files on one of the computers, access is denied. I have tried running the wizard again on all 3 computers, but the same problem occurs. Has anyone got any idea how to solve this, help would be greatly appreciated. Cheers, Stu

  mgmcc 20:32 30 Jul 05

Have you made any changes to firewall settings so that the one PC is now blocking access?

  Stuarthouston 20:34 30 Jul 05

I havent changed anything on the firewalls. I have checked and it is set to let through all ip's on the network.

  LastChip 12:27 31 Jul 05

I, like our Forum Editor, am reluctant to post Registry Hacks, because they can go wrong - Big Time, but sometimes, it is the only way to overcome a problem. So please read this with care and follow the instructions precisely.

CAUTION: DO NOT CHANGE ANY SETTINGS EXCEPT AS INSTRUCTED.

First: Go to Start; Run; and type;
regedit [OK]

Navigate to;

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa

and look for a DWORD restrictanonymous and see what the value is. If it is anything but 0 (zero), close regedit to follow the next part of this post. If it IS SET to 0, this post no longer applies and it isn't the root cause of your problem.

Next, go to System Restore and make a backup of your system, in case things go wrong.

Now, reopen regedit and as a further backup, go to Registry (top left) Export Registry and save a copy of your registry to the root drive (C:). This is a further safety net should the need arise. I don't wish to frighten you and with this hack, things shouldn't be a problem, but you can't be too cautious when dealing with the registry.

Finally, navigate back to restrictanonymous (as above) RIGHT CLICK the DWORD, select MODIFY and change the decimal value to 0 (zero).

A further word of warning, there is a DWORD restictanonymoussam just below the one you want - DO NOT change this.

Now close regedit and reboot your computer with your fingers and toes crossed ;-) and all should be well.

  Stuarthouston 21:01 31 Jul 05

Hi Lastchip. Just to clarify, this registry hack should be done on the computer that files cannot be accessed on? Or the ones which cannot access it. Thanks

  LastChip 21:49 31 Jul 05

If computer "A" can't see computer "B", the hack is done on "B".

  Newuser4165 20:40 01 Aug 05

I had an identical problem as you which I posted here about 2 weeks ago.Unfortunately I still can't solve the probem.The situation has got worse since I updaed Windows on Friday.Initially pc2 in my network could send and receive files to/from pc1.Now pc2 behaves the same as pc1 ie can copy files from 1-2 but can't copy files 2-1.
Very infuriating - thanks a bunch Microsoft.

  Newuser4165 13:14 02 Aug 05

Re my previous post:-
this what Microsoft have say about it on knowledge base article 328170:-
click here;en-us;328170

  Stuarthouston 18:19 02 Aug 05

Thanks Lastchip. Your registry hack worked a dream, im up and running again. Thumbs up mate. :D

  LastChip 19:20 02 Aug 05

:-)

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…