Netobjects Fusion 9, column width problem

  grumpy-git 12:34 19 Aug 07
Locked

I've been using version 7 without problems for years. Got a free full version of 9 off a cd, which I have just installed.

Exported a site as a template from version 7 & imported it to version 9. A problem I seem to have now is the width of columns in an existing table.

The table is 2 columns wide, left-hand one is 371 pixels, right-hand is 376 pixels, but if I preview the site the left-hand column goes much narrower to about 1/3rd screen width & the other column goes to 2/3rds screen width - which of course messes up the appearance of the text in the boxes.

Spent ages trying to work out where it is going wrong, but haven't found the problem yet.

If I create a new table underneath, with same column widths, it previews perfectly.

I'm stuck!! Any ideas please?

g-g

  grumpy-git 15:17 19 Aug 07

No replies yet, but I have made up an "image" of what happens. Top part is part of the table from page design, lower part is from page preview.

You can see the preview is nothing like how it should be.

click here

g-g

  athenrye 00:56 20 Aug 07

hi mate
i use netobjects
ive upgraded before, it did say on the advice stuff that some functions etc woudnt always cross over from version to version

ive had one or two issues and had to start again with the individual function, you might just have to dopy and paste the suff onto a new column

will

  grumpy-git 15:11 20 Aug 07

Thanks Will. I'll play around & see how I get on.

Might keep using NOF7 for the old sites & use NOF9 for anything new that I start.

g-g

  mco 15:57 20 Aug 07

I upgraded from nof 7 to nof 9 last year and, similarly, while most of my site was ok there were a few minor issues - and I just redid them as Will said. If I ever get round to getting nof 10 (though I'm not sure the upgrade is worth it) I might just save it for new sites and keep the old ones in nof 9 to save any potential problems exporting over.

  grumpy-git 20:40 20 Aug 07

Thought I would spend some more time on the "problem".

Created another table, same column widths and with the same number of rows & columns as the one that works perfectly in NOF7.

Started copying the contents of cells into the right hand column & everything was working well, but as soon as something was put into one of the cells in the left hand column - that was when the preview started going wrong. Take it out & it's fine.

I don't understand it.......

g-g

  grumpy-git 18:14 21 Aug 07

Found a copy of NOF8, installed it, then tried importing the site template created in NOF7. This gives the same results as NOF9, so it doesn't look as if the problem is just with NOF9.

Still getting nowhere with this problem.....

g-g

  MicahK 18:18 21 Aug 07

It might be a problem with that page, have you tried making a table on another page?
Micah
LearnNOF.com
forums.learnNOF.com

  grumpy-git 18:49 21 Aug 07

Micah,

I've created new pages within that site migrated from NOF7, and the results are the same.

If I start a brand new site, it works perfectly, but obviously I don't want to have to re-write all my old sites.

Hopefully the html view source from a previewed page (below) should be enough to show the basics of the table, with the columns set at 370 & 376 pixels, but that is not how it appears on screen - the left hand column becomes much narrower.

<TD WIDTH=759>
<TABLE ID="Table4" BORDER=1 CELLSPACING=1 CELLPADDING=1 WIDTH="100%" HEIGHT=1311>

<TR HEIGHT=17>
<TD WIDTH=370>
<P ALIGN=CENTER><FONT SIZE="-1" FACE="Arial,Helvetica,Geneva,Sans-serif"><B>Amendments to existing pages, or updates of “old” photos</B></FONT><B></B></P>
</TD>
<TD WIDTH=376>
<P ALIGN=CENTER><FONT SIZE="-1" FACE="Arial,Helvetica,Geneva,Sans-serif"><B>“Stop Press” - new photos of recent events & new pages</B></FONT><B></B></P>
</TD>

</TR>
<TR HEIGHT=32>
<TD>
<P><FONT SIZE="-1" FACE="Arial,Helvetica,Geneva,Sans-serif">Just some test typing, which fills up the cell & continues onto the next line</FONT></P>
</TD>
<TD>
<P><FONT SIZE="-1" FACE="Arial,Helvetica,Geneva,Sans-serif">Just some test typing, which fills up the cell & continues onto the next line</FONT></P>

</TD>
</TR>

  grumpy-git 22:44 21 Aug 07

I made a copy of the site, which was only about 5 pages in size (but unfortunately with many external links within the tables)

Then I deleted all the pages except one.

Everything was deleted on the one page except for the table, which was reduced to 3 rows and 2 columns.

It looked perfect in "page design" but in page preview the left hand column gets narrower and the right hand column gets wider. But if I reduce some of the characters in one of the right hand cells, it previews perfectly.

If anybody wants to try & see what is wrong, just e-mail me & I will send you the template zip file, which is only 246kb (hope it's OK to suggest that)

g-g

  grumpy-git 22:16 23 Aug 07

Tried getting help from netobjects support. They responded several times, very quickly, but didn't solve the problem.

Reply was "Please try to set the text dimension in pixels not -/+"

I tried that, but it changes the size of text and I can't get it to look the same as it did in NOF7.

Micah, have you any suggestions??????

g-g

This thread is now locked and can not be replied to.

Sony Xperia XZ Premium review: Hands-on with the new 4K HDR phone with Motion Eye camera and Snapdr5…

1995-2015: How technology has changed the world in 20 years

Best laptop for design and art 2017: we test Apple, Dell, HP, Lenovo and Microsoft's best models…

CarPlay tips & troubleshooting guide: CarPlay tips & troubleshooting guide: Get the most from…