NETGEAR DG834PN WILL NOT ASSIGN DNS CORRECTLY

  SANAP 03:19 AM 07 Dec 11
Locked

All of a sudden my netgear wont assign my isp's ip address, instead its picking up the lan ip ie the routers?? first time this has happened and a friend did go into the inner workings yesterday!! will a total reset sort my problem? and as i can only use dyndns presently is there a way i can tweak router to use no-ip etc?

taken me hours to figure out what happened.

sanap

  mgmcc 08:00 AM 07 Dec 11

"All of a sudden my netgear wont assign my isp's ip address"

The router will never assign your WAN IP address (provided by your ISP) to the computers connected to it. It must allocate a LAN IP address to each computer connected to it and "route" the internet traffic to that LAN address. Otherwise, there would be no point in having a router as only one computer - the one with the WAN address - would have internet access.

As far as DNS Server addresses are concerned, routers can behave differently - some allocate only their own IP address, some allocate their own IP address plus one of the ISP's DNS addresses and some pass both ISP DNS addresses through. However, if you're having problems with DNS, you can allocate the server addresses manually without changing the IP address setting which can remain automatic by DHCP.

  SANAP 16:17 PM 07 Dec 11

thank you for reply. I may have phrased my q wrong. I only follow the guidelines when assigning a dynamic ip, ie go to router and just do as instructed. It goes through all the motions but when i click on status it puts up a pop up that says update ok but shows my routers ip no. and when I have dn updater running it shows my ISP ip no, which is what I want but when I try a search with google I get nothing! It has worked flawlessly for years but something has happened to router and I cant figure it. even if i type in isp ip i get nothing!! Then I run dn updater and it reports status good!! I have done a factory reset as well. It was all so easy first time I am now well and truly stuck. Do I need a new router?

I think what I am trying to say I cant create a dynamic dns any more, it appears to work but doesnt.

any help very greatly appeciated. I am lost

  mgmcc 11:19 AM 08 Dec 11

I'm not sure I understand what you're trying to do or what the problem is. If the PC isn't getting the DNS Server addresses, you need to go into the TCP/IPv4 Properties and click the option to "Obtain DNS server address automatically". This can only be done if the IP address is also obtained automatically by DHCP from the router. You can manually assign the DNS address with the IP address on automatic but not vice versa.

If you've allocated a fixed IP address, you also need to allocate the DNS server address.

  SANAP 11:56 AM 08 Dec 11

thanks again, i am getting to the stage that i dont even know myself but learning. the netgear lets you use dynamic dns ie to an outsider it will look like a static address. i set this up about 3 years ago and it worked but all i the did was follow the router instructions and i got a dns from dyndns.org as the netgear is configured for that, they probaly own it. it only stopped working after i used putty to look at traffic in the guts of the router but i did nothing ie no changes so could have been a coincidence. in the past i would untick dns in the router and press apply and then if after a while i would get an email reminder from dns org and then i would just switch back on by ticking box and apply, then a pop up would say update ok. when it stopped working, i did loads of checks and pressed update a few times so dns stop you and say its abuse!! i then downloaded the dns updater software and that sits in system tray and tells me dns is up to date and does this when i reboot. i updated software in router and reset everything and can now ping the dns address as well. so to all intents and purpses its working, just waiting to get outside confirmation.

but the bit that has me confused it when i now check dns stataus via the router i get the message "Unknown return code received!" and it displays the ip address of the router but it may have always done that. after all that i dont know if the router has to show status is ok as well as dns updater in other words can i untick dynamic dns in the router and just use updater from now on. does that make sense????

  SANAP 12:26 PM 10 Dec 11

ok, here is an update for you in case same happens. It was not the router from the outset.. it was the box that was connected to router ie box went faulty. It allowed inbound but not outbound, hence I thought router. And when I changed boxes it was all ok. At least I know a lot more about routers than I did before i started.

and thanks again for you help

Advertisement

This thread is now locked and can not be replied to.

How to get Windows 10 now: how to download and install Windows 10 even if GWX.exe is missing

1995-2015: How technology has changed the world in 20 years

Nokia rolls out spherical camera for virtual reality apps

7 best iPhone web browser apps: Why Safari for iOS is still a better option than Chrome, Dolphin,…