Netbook Windows update service not running

  Ikarus 15:09 PM 23 Jul 12
Locked

I have a netbook with 2Gb of memory which originally ran Win 7 Starter Edition. I bought the Anytime Upgrade, installed it and, up to three months ago, got Windows updates. Then, suddenly, when clicking on Windows Update I got the message "Windows cannot update because the service is not running. You may have to restart your computer". I have run Microsoft's troubleshooter which reports all problems solved but I still get the same message when trying to update. Is there a solution to this please? I have no problems with my desktop computer.

  KRONOS the First 15:15 PM 23 Jul 12

Some steps to follow here. Microsoft.

  birdface 15:16 PM 23 Jul 12

Have you gone into services and made sure Windows Update is set to automatic and running.

  Ikarus 09:05 AM 24 Jul 12

Thanks to both of you for replying. Buteman, yes I went into services and it showed Win Update as running and auto start but it didn't work. Eventually I used one of the suggestions in the M/Soft solutions suggested by Chronus i.e. go to "services", find the " SoftwareDistribution" folder, delete it then go to Windows Update, click on it and download a new version of the programme. I then updated in the normal way and all worked perfectly. Thanks again.

  KRONOS the First 09:08 AM 24 Jul 12

Glad to hear it. If you want to click on the tick to the right it will turn green and indicate a resolution to the problem.

Advertisement

This thread is now locked and can not be replied to.

Sony Xperia Z5 review: Hands-on with the phone which the Z3+ should have been

1995-2015: How technology has changed the world in 20 years

Get your photos turned into illos by some of the world’s best artists

What to expect at the September Apple event: Apple announces 9 September event, sends out invites