Need Help!

  Shahzad 12 Sep 13
Locked

Hi All Experts,

I need help regarding networking computers. I have 8 computers networked.

2 of them running Windows 2000 SP 4 (lets say PC1 & PC2) 2 of them running Windows XP SP 2 (lets say PC3 & PC4) Rest 4 are on Windows 7 (PC5, PC6, PC7 & PC8)

PC1, PC2, PC3 & PC4 are reading data from PC5, PC6, PC7 & PC8.

Now what I want to do that, PC1, PC2, PC3 & PC4 continue to read data from PC5, PC6, PC7 & PC8 but these 4 computer (PC5, PC6, PC7 & PC8) couldn't read the data from in between in simple words these 4 PCs (PC5, PC6, PC7 & PC8) that are running Windows 7, couldn't interlink and read data.

Please help me in this regards,

Thanks in advance.

  lotvic 12 Sep 13

I am not expert on this - but perhaps this is why:

"These days almost every home has a computer network. But if one of the PCs in your home uses Windows XP, you need to change the WORKGROUP name in order to let your Windows 7 PC recognize the Windows XP PCs on the home network.

In order for PCs to find each other, they all have to have to be in the same workgroup. For some reason, Microsoft decided to call Windows XP Home workgroups MSHOME. On the other hand, Windows XP Professional, Windows Vista, and Windows 7 PCs all use WORKGROUP as their workgroup name.

Consequently, unless you change the workgroup name on the Windows XP Home PC, the other PCs can find it and it can’t find them." click here

(I think that means XP can see W7 but W7 can't see XP)

  Shahzad 13 Sep 13

I think I couldn't explain properly. Let me try again.

I have made group and its name is MSHOME. All PCs can see each other computers. I want that only PCs that are on Windows 7 couldn't read each other data. Rest of PCs (Windows 2000 and Windows XP) can read the data from PCs on Windows 7.

Hope it will be clear now.

  lotvic 13 Sep 13

I will ask other members to advise with settings.

Please correct if wrong and add extra information to the following:

All 8 pcs are in a workgroup that you have named 'MSHOME'.

You have changed the workgroup name on all 8 pcs to MSHOME.

  • PC1 W2000 sees and can share files with 2,3,4,5,6,7,8. ok
  • PC2 W2000 sees and can share files with 1,3,4,5,6,7,8. ok
  • PC3 XP Home sees and can share files with 1,2,4,5,6,7,8. ok
  • PC4 XP Home sees and can share files with 1,2,3,5,6,7,8. ok
  • PC5 W7 sees and can share files with 1,2,3,4
  • PC5 W7 can see 6,7,8 but cannot share files
  • PC6 W7 sees and can share files with 1,2,3,4
  • PC6 W7 can see 5,7,8 but cannot share files or read data from them
  • PC7 W7 sees and can share files with 1,2,3,4
  • PC7 W7 can see 5,6,8 but cannot share files or read data from them
  • PC8 W7 sees and can share files with 1,2,3,4
  • PC8 W7 sees 5,6,7 but cannot share files or read data from them
  lotvic 13 Sep 13

I have asked other members to advise click here

  Woolwell 13 Sep 13

Possible firewall problem? Try turning off the firewalls temporarily in turn (2 at a time).

  Shahzad 13 Sep 13

First of all thanks a lot for your help.

Here are the answers of your questions.

All 8 pcs are in a workgroup that I have named 'MSHOME'.

I have changed the workgroup name on all 8 pcs to MSHOME.

PC1 W2000 sees and can share files with 5,6,7,8. PC2 W2000 sees and can share files with 5,6,7,8. PC3 XP Professional sees and can share files with 5,6,7,8. PC4 XP Professional sees and can share files with 5,6,7,8. PC5 W7 sees and can share files with 6,7,8 but not with 1,2,3,4. PC6 W7 sees and can share files with 5,7,8 but not with 1,2,3,4. PC7 W7 sees and can share files with 5,6,8 but not with 1,2,3,4. PC8 W7 sees and can share files with 5,6,7 but not with 1,2,3,4.

I have made shared folders in \users\public\ in all W7 PCs (5,6,7,8) so PC 1,2,3,4 can read and share data in W7 public folders.

I want to restrict W7 PCs so that:

PC5 couldn't see and access public folders of 6,7,8 but 1,2,3,4 could see and access PC5's public folder. PC6 couldn't see and access public folders of 5,7,8 but 1,2,3,4 could see and access PC6's public folder. PC7 couldn't see and access public folders of 5,6,8 but 1,2,3,4 could see and access PC7's public folder. PC8 couldn't see and access public folders of 5,6,7 but 1,2,3,4 could see and access PC8's public folder.

I hope it is more clear now that what I actually want to do.

  lotvic 14 Sep 13

I am not sure, but that is probably a File Share Permissions setting that you need. It is probably in the Advanced settings that you can choose who to share with.

Read through click here to decide which way would be best.

  lotvic 14 Sep 13

Also read: Learn the basic differences between share and NTFS permissions click here

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

Microsoft claims its new VR lens system is better than Oculus Rift's

Apple Music preview: Why Spotify should be scared of Apple's impressive new music-streaming service

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message