Mysterious Storage Controller

  Thurrafork 17 May 11
Locked

Hello all

Just about to do an inplace upgrade (repair) of my Windows 7 64bit OS, due to various irritating problems.

A few minutes into the process a box appears telling me that my ASGKEL8A IDE storage controller won't function properly after the inplace upgrade, and suggests that I update it's drivers first.

I can find it in Device Manager and tried to update its driver from there, but 'Windows could not find drivers for this device'.

So I googled this device and can find absolutely nothing about it!

Anyone know what it is? Or know what would happen if I ignore the prompt to upgrade its drivers?

Thanks.

  Taff™ 18 May 11

I assume you are doing a repair from a Win 7 disk? If so do you also have another disk supplied with the computer that contains the drivers and software?

  mooly 18 May 11

Could be a card reader. I got a similar message clean installing Vista on Acer laptop. Go to the PC manufacturers support site to get driver if so.

Mine said "Mass storage controller" from memory.

  Thurrafork 18 May 11

Mystery solved. The Windows reinstall also advised that I remove Alcohol 52% virtual drive thingy - I did this and the mysterious mass storage device vanished. All is good... I hope. Thanks for the replies folks.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message