My website is loading amazingly slow and i can't find why!

  bentalgad 29 Jun 13
Locked

I used a template from "themeforest" but i changed it a lot and for some reason now it's loading very very very slow (some times 5-10 minutes) and some times it loads fast, and i tried all kine of stuff (moving the site to another domain, loading it in different browsers, disabling different plugins and more...) and i can't find the problem.

Please help me, this is the site: The Vox

(Again some times it loads fast so please try a few times if it's not loading slowly the first time...)

Thanks.

  LastChip 29 Jun 13

There are a number of potential problems on your site, but by far the worst is your DNS lookup and response time which exceeds 2 seconds. That alone accounted for about 20% of the page loading time in my test, which came in at 10.985 seconds.

You're not fully taking advantage of browser caching to any degree and many of your images and other components are not compressed.

78.8% of the requests for your home page are image requests, but they take up 91.2% of the content loading to the browser.

So clearly talk to whoever controls your name servers to get the response time sorted out and seriously attack your images and make them more web friendly.

Your background image is far too large (796.8KB), although in your defence, it is loading after the main content which is good. But never-the - less, it takes a further 2.689 seconds to load (on top of the nearly 11 seconds), making over 13 seconds to absolute completion.

Finally, move all all your script loads to the bottom of the page.

  bentalgad 29 Jun 13

Thanks LastChip.

Even if i remove all the media (mp3's and images) it still loads the site slow so it's not that, and also i'm talking about 5-10 minutes some times and on the other hand some times works very fast so think it must some other kind of a problem other than regular not so good conetnt site size problem.

And yes i also tried the "scripts at the bottom" thing and then it was loading fast without the background and other plugins functions and then it started to load again with the plugins but very very slow...

What did you mean "DNS lookup and response" (Sorry i'm not that advanced) ? it has to do with the host ("dreamhost") or the domain ("godaddy")?

Thanks.

  LastChip 29 Jun 13

DNS is the Domain Name Server(s) - there's more than one.

They are the servers that convert your domain name into an IP (Internet Protocol) address, which is necessary for browsers to be able to find your website.

It is likely, whoever the registrar of your site is (GoDaddy?) will be responsible for the DNS servers. It has nothing to do with where you host your site, although it could be the same if you use your registrar for hosting as well.

If you're saying that plugins cause the problem, disable the lot and then reintroduce them one at a time until you find the culprit. However, be aware of this; sometimes various plugins do not play well together, so you could think you've found the problem, but in fact, leaving the plugin you've just enabled and disabling another, could also give a positive result. In other words, it could be a previously enabled plugin that's causing the problem, but it doesn't show itself until you enable the later plugin. Plugins can be notoriously difficult to nail down when they're causing a problem.

Advertisement

This thread is now locked and can not be replied to.

Windows 10 Home vs Windows 10 Pro comparison: Here are the extra features you get in the Pro version

Behind the scenes at Silverstone, the 70th British Grand Prix: Hisense starts UK push with Red…

How Found created this skateboard, bike and parkour stunts-laden, single-take car ad

Apple Pay UK launch date, UK user guide and participating UK banks | Apple Pay to launch in UK on 1?…

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message