My USB Kindle virtual drive keeps disappearing

  dunderheid 15:01 PM 14 Jan 12
Locked

My new £89 Kindle will not charge. When I plug the USB cable into it, the drive installs itself OK and a message states that the Kindle is charging, then the screen changes to show different screenshots on the Kindle and eventually ends up with a message that the Kindle is not currently charging. All the time this is happening the Kindle USB virtual drive in Windows Explorer keeps disappearing and coming back. If I disconnect the USB cable and reconnect it I get the same thing happening every time.

I took the Kindle back to the shop for a replacement and the self same thing is happening again. I am charging from a twin USB2 port on the PC which is feeding an external HDD which is working perfectly, so I assume there is nothing wrong with the USB port on the PC.

Please help me, I am about demented with it!

  Fruit Bat /\0/\ 15:23 PM 14 Jan 12

Not enough power from port

a twin port will share a 500mA power supply

the kindle appears to need a good supply (my new one would not charge from a mains supplied mp3 USB charger)

If you disconnect the HDD you will probably find it charges OK

or try another port

  Fruit Bat /\0/\ 15:24 PM 14 Jan 12

Also make sure you have ejected the drive on the PC while you leave it charging (so its not in PC mode)

  dunderheid 15:39 PM 14 Jan 12
  • thank you for your very prompt reply to my post, Unfortunately I have tried your suggestion about disconnecting my external HDD and only taking power from this port for the Kindle alone, and it has made no difference, but all I did was switch the external HDD off,however I will try unplugging it and see what happens. Ths strange thing is the first Kindle charged fine the first time I plugged it in, then when I tried a second time all this bother started.

I would also like to say that I can plug a Sony Digital camera into this same USB2 port and never get the symptoms I have mentioned about the drive disappearing and coming back, then again maybe a Kindle operates differently. I am at a loss!

  dunderheid 15:45 PM 14 Jan 12

I have just unplugged the external HDD and even with the Kindle getting the full power from the USB port there is no change.

Do you think it is possible that even this second Kindle is faulty or is it a fault in my PC?

  Fruit Bat /\0/\ 16:25 PM 14 Jan 12

Assuming your using the front ports on the PC?

try using a rear port

  dunderheid 16:33 PM 14 Jan 12

I don't have any front ports. In fact this USB double port is a card I fitted myself. All the other ports are only USB1

  Fruit Bat /\0/\ 16:44 PM 14 Jan 12

USB 1 is fine for charging as you are only needing the 5v supply connections

  lotvic 17:10 PM 14 Jan 12

It seems your USB port is underpowered, here is a discussion of the same problem you are getting amazon.com/forum/kindle

I suggest you try the other USB ports other than on your card and if that doesn't work then you may have to get a USB-to-AC adapter and charge your device from a wall outlet.

Advertisement

This thread is now locked and can not be replied to.

How to get Windows 10 now: how to download and install Windows 10 even if GWX.exe is missing

1995-2015: How technology has changed the world in 20 years

Nokia rolls out spherical camera for virtual reality apps

7 best iPhone web browser apps: Why Safari for iOS is still a better option than Chrome, Dolphin,…