My ROM drive not recognised What should I?

  Amer 08:48 20 Jun 04

I have a Sony computer running on Windows XP, Pentium 4 and have 2 disc drives, a DVD RW and DVD drive.

My main DVD RW Drive is fine but the other DVD drive is not being recognised. Device manager says all is fine. In Windows Explorer, again any disc inserted is not recognised. Never been a problem before...Any ideas anyone?

Any help appreciated


  wags 09:02 20 Jun 04

I had exactly the same problem. It sounds like the drive is dead I'm afraid. I had a Sony DVD rom drive pack up after only 6 mths. The replacement provided under warranty also failed within minutes. I then had it swapped for an LG and that's been fine.

  johnnyrocker 09:09 20 Jun 04

you could try uninstalling it in device manager re boot and see if windows will ressurect it.


  AlanHo 09:57 20 Jun 04

I had a similar problem with a new DVD burner. It installed OK but it would not recognise any discs - it kept asking me to insert a disc.

I tried uninstalling with device manager and starting all over again - but no joy - this time it incorrectly showed up as a scsi drive rather than IDE.

I then took the side off my computer and made sure the connection cables to the drive were fully home - voila - windows found new hardware and it installed correctly and has been fine ever since.

Hence chech your cable connections are firmly home.

  barnacarry 10:39 20 Jun 04

I've had similar problems with a CD drive and found this to work. Try it.
Go to My Computer, Right click and click on Properties, Hardware, Add Hardware Wizard, Next.
Then click on 'Yes, I have already connected the hardware' then scroll down to your ROM drive and click on it and click Next and then finish.
Your rom drive should then miraculously appear in 'My Computer'.
Good luck.

  Amer 12:49 20 Jun 04

Have tried the barnacarry option but to no avail, so will check cable next

  Amer 12:50 20 Jun 04

Have tried the barnacarry option but to no avail, so will check cable next

  PSF 14:00 20 Jun 04

It looks like it could be dead, one other thing you could try is to remove the Secondary IDE Channel and re-boot. If it finds the drive it should re-install it.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…