my pc doesnt start up

  lennaerd053 21:06 06 May 15
Locked

when i press the power button everything starts fans, keyboard, lights, screen etc. however the screen just wont go past the first part where it shows the producer of my laptop. i really hope someone can help me with this issue.

My laptop is a lenovo y500.

  Fruit Bat /\0/\ 22:35 06 May 15

disconnect all power leads and remove battery

press and hold power button for 30 seconds

reconnect mains and retry.

  Dashing_star 05:35 07 May 15

Hello, Please swap your RAM and reseat it properly..

  Frost_WD 12:51 07 May 15

Hi lennaerd053,

Could you please tell us if you can hear any beeping sounds from you motherboard? Resetting the CMOS battery is a really good idea, testing the RAM too. You can also try the RAM and you PSU on a different machine if possible. Also, do share if you had any other symptoms prior to the occurrence of the problem. Also, make sure all you cables and components are firmly in place. If you have warranty on the laptop you could consider contacting the manufacturer and asking for an RMA.

Hope it helps,

Frost_WD

  lennaerd053 14:21 07 May 15

i am willing to try anything but does opening the laptop break warranty? eventhough i already did that to check the graphics card for dust.

@fruit bat: your method didnt work :( tnx anyways :D

ill try the other 2 methods.

@frost: well everything starts keyboard lights up i can hear the fans its just the screen that wont go past the producers name.

one new thing i noticed is that when i press ctrl+alt+del my screen goes black and goes back to the same screen again

@dashing i will try the ram eventhough i did try getting them out yesterday it felt like i at to put to much power on the ram sticks which made me afraid of breaking them. so is there like a special way to remove them?

tnx for the replies gusy :)

  onthelimit1 15:23 07 May 15

What Operating System? If W7, worth trying a repair using a W7 CD. If W 8 / 8.1 there are ways to access Advanced Startup from which you can refresh the laptop without losing data.

  Fruit Bat /\0/\ 15:24 07 May 15

It sounds as if its not completing BIOS and moving on to the hard drive to boot windows.

Manual

Remove the RAM they are clipped in either side see page 41 and try a boot with the memory out - it will beep at you - unplug and refit the RAM and retry. It may well kick the machine through BIOS.

If still same try removing and refittting the HDD to remake the connection then retry to boot.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

The updated 'Corel Painter inside Photoshop' plugin ParticleShop offers new brushes

Best running headphones | Best sport & fitness headphones: 4 brilliant pairs of wireless…