Is my motherboard dead?

  Phrixos 21:03 07 Nov 07
Locked

(Tried to post this once before--but something went wrong, so if this thread appears twice, sorry.)

"POP!" --and that was it. Suddenly, my previously all-singing, all dancing PC displayed all the life of a used bottlecap.

No POST, no LEDs, no hums. Nothing.

Blew out all the dust (there wasn't much.) Tried a new Power Supply, then a new CPU. Then disconnected everything, except the PCI cards. At this and on using the power supply switch, the LED flickered--once, meekly--the CPU fan twitched a bit and the chipset fan spun for about half a second, then--nothing. Tried this several times. Always the same. Nothing.

I'm assuming my mobo is fried--but could I be wrong?

ATB,
Phrixos

  recap 21:07 07 Nov 07

Did you try powering the PC up with all cables disconnected from the back of the PC to see if you got any post beeps? Also did you remove the memory, reseated all cards?

  woodchip 21:10 07 Nov 07

It would be dead if he had, with all cables disconnected from the back of the PC

  Radix Lecti 21:29 07 Nov 07

Exact same thing's just happened to me :(

Pah, it's going to be a dull week... I may even have to <shock horror> go out :o|

Keepin' my eye on this one.

  woodchip 22:34 07 Nov 07

Try a Working PSU that you know works. And remove all Cards other than Graphics just one stick Memory and diconnect data cable from all drives See if it will boot to BIOS. If not try clearing CMOS with Jumeper or remove Motherboard Battery then reinstall after 10 minutes

  Phrixos 23:13 07 Nov 07

Lots of advice, guys. Thanks. Will try it all in the morning.

(Where there's a Forum, there's hope!)


ATB,
Phrixos

  laurie53 08:39 08 Nov 07

Hesitate to state the obvious, but the fuse in the plug is worth a try - it's happened before!

  Phrixos 10:36 08 Nov 07

Disconected everything, except CPU, one DIMM, and the Graphics card. Removed and replaced the battery, and reset the RTC. Same result: slight flicker of fans and LED, then Nada. (Tried it again with even the graphics card removed. Still nada.)

I guess this is the very definition of a dead board (an Asus A8N-SLI Deluxe, btw--and, just outside the guarantee!) Unless somebody comes up with a miracle, this means a new board--which, given Microsoft's OEM policy (the software dies with the board) means a new Win XP Pro and new MS Word. (Visions here, of that old joke about all the organs of the body arguing over which was the most important.)

As this has ceased to be a Helproom issue, I am carrying it over into the Consumerwatch Forun, under the heading of "Dying with a Motherboard".

Thanks, people, for all your help. (I'll leave this thread open for a bit--just in case there is a miracle-worker out there.)

ATB,
Phrixos

  woodchip 14:19 08 Nov 07

I will go with the Board

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now