Is my graphics card finished?

  Will 12 Dec 11
Locked

I have been at sea and come back to be told the desk top computer stopped working 4 weeks ago, now useing the laptop through wireless. The deskpot screen is saying no signal to the screen... I have connected the cable to my laptop so knw the cable and screen are okay.. does that leave the graphics card only? Could it be anything else?

  buteman 12 Dec 11

Sounds as though it is the graphics card.Have you tried starting in safe mode to see if it would work.

  buteman 12 Dec 11

You could take the graphics card out and see if it starts with the on board graphics.

  KRONOS the First 12 Dec 11

Thats assuming you have on-board graphics.It very much sounds as though your GPU has died,you do not say what it is and I am assuming that you do not have a spare to try. So see if you can borrow another GPU or buy a new one.Depending on your card this might not be very expensive.

  Woolwell 12 Dec 11

Does the desktop boot? Do any lights come on, make a sound, etc?

  Will 12 Dec 11

Thanks everyone. Didin't think of trying the nboard graphics but think it is the Graphics card just needed the second opinion.

  Will 12 Dec 11

I have replaced the graphics card and there is no change. I now suspect perhaps the CPU is the problem. On turnng the unit on there is no movement or sound other than the fan.. can anybody suggest anything?

  Woolwell 12 Dec 11

PSU possibly. I did wonder earlier on when I asked about lights, sounds, etc. Were there any power supply problems whilst you were away?

  Woolwell 12 Dec 11

Could be a number of things including motherboard.

  KRONOS the First 12 Dec 11

Can you get into the BIOS? Usually done by tapping a particular key, delete for my motherboard, but it will tell you on one of the POST screens. If you can get in then you should at least see what your mobo is registering.

You say that there is no movement/ noise other than fan. Which fan? What about the various lights from optical drives and keyboards, does the hard-drive spin?

  Will 12 Dec 11

Can't get anything on the screen at all, it isn't going through at all. The fan is going on the CPU, if the PSU was knackered would it work?. The light on the front came on, no flicker or anything, it is like it gets stuck on the POST... and I couldn't here anything on the HDD(Both) Very odd???

Advertisement

This thread is now locked and can not be replied to.

Windows 10 Home vs Windows 10 Pro comparison: Here are the extra features you get in the Pro version

Why Formula-e needs to go faster

How Instagram spots trends

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message