My computer has to be started in a strange way

  Wr1ter2b 19:46 30 Dec 08
Locked

I don't know if anyone can help. I built a computer a few months ago and it was working perfectly until about 3 weeks ago when it would not start properly. When I pressed the power button the fans would spin and the DVD drive would start but the hard drives and the GPU would not start. In order to get the computer to power on I have to turn the surge protector socket switch off and on quickly and then the hard drives spin and the GPU provides a display on the monitor. Once on the computer works a treat.

I suspect the PSU might be at fault but it is brand new (Be Quiet 550 Dark Power) and came highly recommended.

Asus P5QL-E Motherboard P43 chipset
Q6600 CPU
Dark Power 550 Power Supply
ATI Radeon Sapphire 3600
Antec 300 Case
Samsung Spinpoint 500 Hard Drive
Samsung Spinpoint 250 Hard Drive
Samsung 2032BW Monitor
Pioneer DR16 DVD drive
4GB Corsair DDR2 Ram (PC2-6400 XMS2)

Thanks in advance

D

  Technotiger 19:48 30 Dec 08

It does sound like the PSU, even new ones can be faulty, as I know from personal experience.

  bluto1 20:42 30 Dec 08

I agree with Technotiger, but try something else just to check. Disconnect from your surge protector and plug in at another point then try switching on again. If that cures it then it's the surge protector board, if not then I'd have a closer look at the PSU. All the best.

  rdave13 20:51 30 Dec 08

Sounds like a bad connection somewhere.

  rdave13 20:57 30 Dec 08

Another thing to check is make sure the power socket is firmly pushed in to the PSU fitting, can be a bit tight sometimes.

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced