MSI MOBO BIOS updates

  Sisha 07:41 26 Apr 03
Locked

I am having a few problems with with my system and have narrowed it down to what I beleive to be the latest BIOS I downloaded for my KT3 Ultra 2 series MoBo. I have heard rumours about dodgy BIOS updates and I have to agree its little strange how they work. Their auto update software constantly informs me that there is still another bios update waiting for me to dowload?
Does anyone else have this problem?
I really want to find an older version of the BIOS and install that. Not had much luck with their site. Does anone know of a good resouce site for MoBo bios's?

  AndySD 08:22 26 Apr 03

KT3V (ms-6172) click here or KT3M (ms-6596) click here

  AndySD 08:27 26 Apr 03

Ooops forgot to mention "Their auto update software constantly informs me that there is still another bios update waiting for me to dowload?" Even when it shows the the update as the same bios thats installed....yes seen this one I just turned off the MSI Live Update.

  Sisha 08:32 26 Apr 03

will check those

  Sisha 08:41 26 Apr 03

I cant find anything in relation to those. I did however find something on the usa site but wondered if that would cause a problem or (because its US). I am trying to find an old version as the most up to date version seems to be killing my system with stuttering problems!

  ardvarc 08:52 26 Apr 03

What is the model number of your MoBo and the BIOS version and date. On a search I am getting 6380E or 6593. On the latter the BIOS date is 22/11/02 version 1.2 and the former 24/2/03 version 5.7.

click here

  ardvarc 08:55 26 Apr 03

Think I have those versions the wrong way around but you get my drift ;-)

  AndySD 08:55 26 Apr 03

You say you have an MSI KT3 MoBo it will also have a number eg ms-6172 if you dont know it try Belarc click here. Have you tried checking the settings in the bios since updating the bios..... eg is the processor still at the correct speed (Have a look in control Panel/System) in the bios check dma is enabled and thet the AGP settings have not been set back to default.

  Sisha 08:58 26 Apr 03

I think I have found what I want (thanks to your help) The model number is KT3 ULTRA 2 R ms-(6380E)
I already have to most update version but since installing it, my system is very wonky

  Sisha 09:08 26 Apr 03

I have checked most of the settings but m not sure of what the AGP settings should be (I never had to play with them before) I ma using a PNY GEFORCE 4 (mx440) 64MB graphics card. Not sure how fast or whatever AGP settings are optimal?

  AndySD 09:26 26 Apr 03

AGP settings

Set to 4x and the Appature to 64 mb or half you RAM so if you have 512 mb RAM set it to 256.

Also have you changed anything else since updating the bios.... eg MoBo drivers or NVidia drivers?

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…