MS DOS Program under Win98SE

  dewskit 12:25 13 Mar 05
Locked

I run a Database Program (Data Manager Professional) under DR GEM in a DOS Window, which has run perfectly on Win98SE for some years.

(Pause for hysterical laughter to die down ...)

It is very easy to use and does exactly what I want, hence the continued use.

After a clean re-install of Win98SE the keyboard has apparently 'gone American' on me - in particular the #, ~ and £ characters are not where they should be. As some of these are used as formatting on Reports, or # enters a full date in one key press, I would like to re-establish the status quo. (Everything works as it should be in Windows Programs however)

I suspect there should be a Config.sys, or similar file which enables the correct keyboard layout but cannot remember how to enter it, or what it should contain.

Anyone with a longer memory that can help please?

Thanks in advance

  FelixTCat 12:41 13 Mar 05

Try going into Control Panel and then it may be Regional Settings, International Settings, (or something like that). Then set the location to United Kingdom - I think there is a whole range of options for date/time settings, keyboard, language etc, but the ones you ant are keyboard - British/English and language - British/English.

Sorry, this too is from memory, but if you look around for similar sounding entries, I'm sure it's there somewhere.

  Peter 12:55 13 Mar 05

.

As FelixTCat suggests the Regional Setings in the Control Panel should be used to select English (United Kingdom). You can also select Number (Decimal Point), Currency, Time & Date settings.

While in the Control Panel use the Keyboard Properties to select English (British) on the Language tab.

Peter.

  dewskit 13:00 13 Mar 05

FelixTCat & Peter

Thanks for the suggestions, but I have already checked all the Language/Region and Keyboard settings in Control Panel.

As I said, everything works correctly in Windows Programs, only under DOS it doesn't!

  pj123 13:07 13 Mar 05

Start your PC in DOS mode and at the C:\ prompt type in keybd uk and press enter.

Try is now.

  pj123 13:09 13 Mar 05

Sorry, meant to say you may like to enter that command into your autoexec.bat file.

  dewskit 14:22 13 Mar 05

pj123

Tried that and rebooted, no difference.

Am I right in assuming it is correct to edit the CONFIG.SYS file by going START, Run and typing Edit CONFIG.SYS? This is what I did, and it showed an expty box, into which I typed Keyboard UK

  dewskit 14:23 13 Mar 05

Sorry

Meant to say AUTOEXEC.BAT

  Diemmess 17:44 13 Mar 05

I think (from memory) the line is Keybuk

  buscrew 18:14 13 Mar 05

The correct way to alter your files is in the run box type sysedit, from there you can see all your files.

  octal 18:24 13 Mar 05

You have to enter these lines in both the CONFIG.SYS and AUTOEXEC.BAT

For CONFIG.SYS:

device=C:\WINDOWS\COMMAND\DISPLAY.SYS CON=(ega,,1)

country=044,850,C:\WINDOWS\COMMAND\COUNTRY.SYS

For AUTOEXEC.BAT:

mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)

mode con codepage select=850

keyb uk,,C:\WINDOWS\COMMAND\keyboard.sys

Just cut and paste them so you get all the comers and spaces in the right place.

We run a Borland database in DOS at work, so we have the same problem.

This thread is now locked and can not be replied to.

iPhone 7 review: a range of small updates add up to an excellent phone

1995-2015: How technology has changed the world in 20 years

How New York’s Stylin’ Seniors became a golden social media campaign

23 Apple Watch tips & secret features: Master your Apple Watch, Apple Watch Series 1 or Apple…