Mouse/mouse connection/mouse port not working

  rossini 18:24 24 May 03
Locked

My mouse/mouse connection is misbehaving. My PC was working fine yesterday. When I switched it on today, however, the pointer on the screen wouldn’t move with my mouse. My mouse is a Logitech Cordless. I changed the batteries, I disconnected it and reconnected it and restarted my machine a number of times but still it wouldn’t work. I looked at the Hardware Manager but gleaned no useful information. The only other thing that suggested something wasn’t right was when I clicked on the Logitech icon on my desktop. Normally it shows you the battery levels of both the keyboard and the mouse but this time it only showed the keyboard.
The end of the cable from the mouse receiver is a USB plug, which you then attach to a mouse port adaptor so that you can plug it directly into the mouse port on the computer. I removed the adaptor and plugged the naked USB plug directly into a spare USB port. The mouse then started to work immediately. I therefore have a solution for the short-term. I do not, however, want to leave the set-up like this, as I am now engaging a USB port for the mouse unnecessarily while the dedicated mouse port lies redundant, plus when you click on the Logitech icon it still doesn’t register the mouse.
Any ideas as to what’s gone wrong? My PC hasn’t sustained any physical impacts between yesterday and today so the USB-mouse port adaptor shouldn’t be damaged.

  Rayuk 18:58 24 May 03

Have you tried pressing the small button on the mouse see if that helps.
Previous thread today with similar problem

  Rayuk 18:59 24 May 03

Sorry
The small button is on the underside of the mouse,on mine its a little red dot,you will need a biro or pencil to press it

  rossini 01:09 25 May 03

I've already tried pressing the reset button, both on the mouse and on the receiver but it didn't help. I don't think that this is the problem as the mouse works when the receiver cable is connected directly to the USB port so the receiver is definately picking up the mouse transmission.

  Rayuk 13:00 25 May 03

Have you tried reinstalling the latest drivers.
Did the mouse show up when it was on the usb port?
This is a thread on a similar theme
click here

  rossini 20:15 26 May 03

The mouse did show up when it used the USB port. I don't think there are any new drivers for the mouse. Anyway, I don't think that could be the problem- why would it suddenly stop working one day from the port it's always been plugged into? My PC did a minidump yesterday- perhaps something more serious is wrong :-(

This thread is now locked and can not be replied to.

Hands-on: Samsung Galaxy S8 review

1995-2015: How technology has changed the world in 20 years

Samsung's beautifully designed Galaxy S8 makes for better VR experiences too

47 iPhone camera tips to help you take better photos