mouse stopped working

  quakergirl 08:34 14 May 07
Locked

My mouse has stopped working for no apparent reason. I've got a dual boot setup with windows xp and linux and it doesn't work in either. Nor does another mouse and both work on another PC. I've enabled mouse keys and I can do a certain amount with keyboard shortcuts, but its really very difficult without a proper mouse.

If I turn the PC off and unplug the mouse, then plug it back in after startup, I get a message saying 'usb device not recognised. One of the usb devices attached to this computer has malfunctioned. click this message for assistance.' If I then click the message I get another saying a similar thing and that the solution is to replace the device. Which I've done and it doesn't help.

I've done umpteen restarts and run virus scans, etc, but I'm beginning to think my only option is to reload both windows and linus.

Any ideas?

  jack 08:51 14 May 07

If the device is a USB device- how is it connected?
Via a hub? And is it a powered hub?
If yes to both of these then plug it into the MoBo connector directly
Or is it a PS2 device?
If you are using a USB device then it is a good idea to have a PS2 device permanently plugged in as a back up.

  birdface 09:03 14 May 07

Have you tried deleting mouse driver in device manager and rebooting computer,

  quakergirl 10:51 14 May 07

thanks guys!

It's a usb mouse, but i plugged it in with a PS2 adapter and bingo!

So what's the problem with the usb ports then, cos I tried it in 3 different ones. Will now always be a problem on this PC or will it disappear if I reload the OS?

  Trackrat 12:19 14 May 07

Have you checked in device manager to see if there are any red or yellow marks against the USB devices?.

  birdface 13:19 14 May 07

There have been a couple of threads in the last 2 months with the same problem,Unfortunately I cant remember how they were fixed.It may pay you to tick the square box,Press resolved, And open another thread with USB Ports not Working,Or something like that,You may get a better response.

  quakergirl 15:35 14 May 07

Thanks, I did mark it resolved as it essentially is, but I will check the usb issue, although it does seem strange that other things work in the same usb ports.

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Framestore’s haunting post-WWII title sequence for new BBC series SS-GB

Best iPhone games 2017 | Best iPad games 2017: 162 fantastic iOS games that you need to play right…