mouse software wont start

  jagx400 19:41 13 Dec 04
Locked

I recentley started using a Trust 450 cordless mouse, It worked fine untill a moment ago, the pointer would not move so I used the cursor keys to reinstall the drivers using the disc that came with the mouse, it now works but the software (batt power , extra buttons etc) will not function.

If I check in control panel it says there is just a microsoft mouse installed and the standard microsoft drivers. The program shows in the menu group and if I double click it the program does nothing, I have uninstalled the drivers and tried again, updated the drivers but still no joy, even ran a reg cleaner to get rid of any crap, but to no avail........help

  Dorsai 20:18 13 Dec 04

How long ago did you install it?

Perhaps the batteries are getting on the flat side. Try new ones.

If that dont help.

I would uninstall all mouse drivers. Reboot the PC, let windows auto detect the mouse (complete with new batt's just in case) and then use the option to install software from disk.

For starters.

  jagx400 20:25 13 Dec 04

Have done all that and still no luck, the mouse works fine just the software wont start to allow the extra functions

  jagx400 21:26 13 Dec 04

bounce

  Totally-braindead 23:47 13 Dec 04

Just had a look at the Trust website and theres 2 mice mentioned with the 450 prefix suggest you dowlaod new drivers as I notice they've recently updated some for SP2, don't know if you've recently updated your windows or not but the new drivers will do no harm and may solve your problems.

  jagx400 16:23 14 Dec 04

no done that and the prog still wont start

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…