Mouse problems

  lonemascot 21:21 07 Aug 09
Locked

I could be writing in a box (like this one or the url address bar) and after a few seconds the window somehow deselects itself as if I have clicked the mouse on a different window and I can no longer write in the box until I actually re click the box. It does it on all programs and is really starting to irritate me.

Furthermore, in a couple of programs the mouse pointer disappears completely and I lose mouse functions until i reset the computer using the keyboard. When it does this computer functions work fine, i just can't click anything.

I have a Logitech MX700 wireless mouse which has always worked till now. Windows OS is Vista.

Any ideas?

  Sea Urchin 21:34 07 Aug 09

New batteries for the mouse?

  lonemascot 21:35 07 Aug 09

I have a dock that recharges them. There is an indicator light that flashes red when they are low but it hasn't been doing that.

  Sea Urchin 21:40 07 Aug 09

Maybe this might help?

click here

  Technotiger 21:44 07 Aug 09

Have you tried a different USB slot?

  Sea Urchin 21:45 07 Aug 09

The mouse is wireless

  Sea Urchin 21:49 07 Aug 09

Sorry - ignore my last posting

  lonemascot 21:59 07 Aug 09

Thanks for link but this is not what is happening.

The box I am writing in becomes deselected somehow and i have to reclick in it to carry on writing.

When the mouse disappears, it is permanent until computer is restarted.

This a fairly recent problem and settings have not been changed since i bought the computer.

  Technotiger 22:05 07 Aug 09

Try different USB port, or Try a System Restore back to when it was all ok.

  lonemascot 22:15 07 Aug 09

A system restore is a bit excessive for something that should surely be an easy fix for you computer boffins.

  Sea Urchin 23:00 07 Aug 09

This is called "stealing focus" where another application causes the window to become inactive. If you download TweakUI (it's actually for XP but this fix does work on Vista as well) and then go to General - Focus - and then tick Prevent Applications from Stealing Focus. Click Apply and OK.

Also, have you tried using another mouse (maybe a wired one)?

Otherwise it is quite likely to be malware. A-Squared Free has a good record in removing mouse bugs.

TweakUI
click here

A-Squared Free
click here

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now