Mouse installation

  faintly curious 01:54 06 Jun 04
Locked

I've just installed a serial mouse onto a Win 98 system. Although the mouse works perfectly, every time I start the system I am greeted with the annoying message that I will need to restart the system in order to complete the installation. Any ideas on how to get rid of this message please?

  Djohn 02:16 06 Jun 04

Try removing the driver from device manager and reboot your PC, it may re-install itself fully.

While your in device manager check to see there are no yellow exclamation marks against the mouse or other hardware. j.

  faintly curious 00:53 07 Jun 04

Thanks for the suggestion but I've already tried the obvious. And yes, although there is an exclamation mark in Device Manager, the mouse is actually working perfectly once the system has started up. All I need to do is get rid of the annoying message.

  Stuartli 10:57 07 Jun 04

Try Removing the driver and the mouse again and then reboot to allow Windows 98 to Install New Hardware - let Windows use its own bsic driver if you have been using a driver supplied with the mouse.


This Microsoft.com link may hold a clue as well:

click here

If the link doesn't work, key in 188572 into the Knowledge Base search engine.

  Stuartli 10:58 07 Jun 04

...should read "let Windows 98 use its own basic driver if...."

  faintly curious 11:48 07 Jun 04

Thanks Stuart but this doesn't describe the problem. The mouse is clearly correctly installed using the Windows driver as it works fine. It's just the message I get when the system is started is the same in Device Manager - that the system needs to be restarted in order to complete the installation - despite the fact that the mouse and driver have been removed, re-installed, and the system rebooted. Again the mouse functions perfectly, I just need to get rid of the error message.

  Djohn 14:24 07 Jun 04

Not sure what to suggest as your next step but to clear the message on boot up you will need to find what is causing the exclamation mark in device manager. Seeing that you are using the serial connection rather than a USB or PS2 type, have you any other serial hardware connected? If so try removing that and see if the message disappears.

The exclamation mark is telling you something is not quite right in the setup of the mouse driver or it is conflicting with some other hardware. Fix this problem and the message will go. Sorry I don't have the answer but I'm sure someone will know.

Regards. j.

  Stuartli 14:26 07 Jun 04

In Device Manager check out the exclamation mark by going into the mouse's Properties and then the Resources tab - it may indicate a conflict.

  faintly curious 20:26 09 Jun 04

No luck guys - there are no conflicts on the system, the mouse it set up to use IRQ 12 and othing else is using this. I tried connecting the mouse to another port but the same problem occurs, looks like I'll have to put up with it or get another mouse!

  Stuartli 09:24 10 Jun 04

Looks like you are caught in a trap...:-)

  THE TERMINATOR 23:47 12 Jun 04

Is this error refering to something other than your mouse that you may have installed at the same time, and does the error occur if you uninstall the mouse? TT

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

Best Christmas Agency Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…