Modem problem

  mun 11:37 25 Jul 04
Locked

Hi, can anyone help with a modem/port problem??
I have a PC with 2 hard drives, 1x windows98 and 1x XP. The modem has been working fine on Win98 HD but when I installed the XP Pro on the other HD, install the XP drivers ok and then use the Internet wizard to sort the connection side out I have the following problem;
Although everything installs ok, the connection can’t be made because it says “unavailable-device not found” under the connections. When I go to the modem options its all been installed ok along with the drivers. However it lists the port number as COM4.
Under the internet connections properties, it has set it up as COM1 and hence its shadowed as it can’t find the modem. (It has “connect using Modem-Unavailable device COM1”. I’m also wondering why it doesn’t pick up the modem name as “SoftK56 DataFax” as its shown under the Control Panel-Phone&modem options)
I seem unable to change it from COM1 to COM4 (may be the Connection Section doesn't see COM4 for some reason??) which I expect will solve the problem.
Does anyone have any bright ideas??

Thanks in advance
John

  stalion 14:43 25 Jul 04

refresh

  mun 19:01 25 Jul 04

hi stalion, refresh what? If you meant do another connection setup thru the wizard, I've already done that without success. It seems that no where along the line do you get to choose the modem and therefore COM port that you want.
Any advice gratefully received
John

  woodchip 19:17 25 Jul 04

What com port is it using in 98

  woodchip 19:25 25 Jul 04

back after corry

  mun 08:37 26 Jul 04

Hi Woodchip,
I checked the port for the win98HD and it says COM3!! Since Ive just tried the modem on Win98 and it works fine how do I change the port naming on XPPro to COM3? I presume this is the right thing to do-certainly the physical location of the modem has not changed!
thanks
john

  woodchip 12:57 26 Jul 04

You need to first remove the Modem in Device Manager. Then in Control Pannel\Add Hardware double click the icon choose not to scan but to choose from list also have your Drivers Disc in the comp, now from the list choose modem and click have disc, it should ask what port you want to install choose com3. If it does not go You may need to go into BIOS to enable the com port

  Stuartli 13:24 26 Jul 04

The refresh is to bring the thread up to the top of the listings again.....

Re your Internet connections. I think that basically you will need to set up XP using the Network Setup Wizard to handle both accounts as the host (Internet Connection Sharing).

In XP click Start>Programs>Accessories>Communications>Network Setup Wizard; read up any information and then click Next.

The next window should provide more information about home networking, complete the preparation tasks listed and again click Next.

A Select a Connection Method window offers options to describe how XP connects to the Internet. I would suggest that XP is the choice and that your 98 OS will connect to XP.

Select the appropriate button and again click Next and the Internet Connection window should appear. In the box listing all entries in the Network Connections folder select your connection to the Internet and click Next.

If you are using dialup, the wizard will prompt you to dial a connection; in the window enter a description for your computer and desired computer name.

Study the changes that will be made to your system and click Next. XP should then automatically configure all of the software and hardware componnts for networking, according to selecitons made when running the wizard.

Click finish and reboot for the changes to take effect.

Then run the wizard on your 98 setup using, if necessary, the XP CD-ROM - 98 supports it.

If you want to find out what the Home Networking Wizard did or if you have problems connecting the two operating systems together, go to the ork Connections folder and check out the LAN connection's Properties.

In the General tab ensure Client for Microsoft Networks, File aned Printer Sharing for Microsoft Networks and Internet Protocol (TCP/IP) are all selected.

Then right click on what you want to share (Internet) and click Sharing to configure it.

Now you need to let IE, OE and other applications using the Internet how to do so through ICS.

In IE click Tools (OK any error message) and then Internet Options>Connections. Select any eixsting dialup connections in the window and then Remove. The default LAN setting should now be used by OE (and OE as it shares IE's configuration).

  Stuartli 13:31 26 Jul 04

I've suggested the above because, as I inferred, I think that with having two separate hard drives and different operating systems, XP will regard them as separate "computers".

Just a hunch but, hopefully, it will work.

  mun 18:40 26 Jul 04

Thanks Woodchip & Stuartli,
Unfortunately I'm still unable to change the COM setting.
Firstly I tried Woodchips suggestion but it changed the COM setting itself from COM4 to COM5. I can't see a way to change this manually under BIOS. I'm running AMIBIOS and tried the "PCI/Plug & play setup"...i tried changing the "plug & Play aware O/S" from yes to no and reinstalling but no luck. There are "DMA channels" and "IRQ"channels that are numbered but no mention of a modem.

Secondly, I tried StuartLi's suggestion. By the way I should mention that I run the win98 HD and the XPPro HD as hosts separately. ie I just change the leads over from one to another when I need the other.Thus they're both setup as C drive but never on at the same time, hence my confusion as to why 98 works for the modem but XP doesn't. However, I went thru your suggestion and set it up as you said (you've actually also answered a question I would have had next month when I network this PC with another, when the broadband is turned on!! ). The network install went okay, but I never got a chance to choose the COM port and it still comes up as COM5.I'm unable to change the COM port under Modem options.

Thanks very much both of you for your help so far,is there anything else you can suggest I try??
John

  woodchip 21:23 26 Jul 04

try this instead of trying to sort the modem, go back to control panel and go through what I posted before for the add new hardware wizard, only this time instead of selecting a modem select a com port to add and choose com3 then try loading the modem again.

PS remove the modem and the Com 4 in device manager before doing the above

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Why ecommerce hasn't taken off on social media

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's expensive and powerful…