Mio 268 Plus Digiwalker

  COLFY 17:42 01 Dec 07
Locked

I bought one of these from a trade supplier on
the internet recently and it lasted one whole day before a large black rectangle kept appearing and blanking out the screen. It was returned to supplier. Then like a fool I bought a used one on EBay ( the supplier assured me that his computer recognised it and it worked for him) but with me I only get a blank screen after the initial photo of a satellite and the the message,'USB device malfunction. Windows not able to support it'. Has anyone out there ever got one of these to work? I run XP Prof SP2.Finally, wherever does one find a repairer? The Mio site gives absolutely no help with this.

  Fruit Bat /\0/\ 18:21 01 Dec 07

USB equip not recognised
Try switching the computer off and at the wall. Then hold the start switch in for 30 seconds or more, and then re boot.


If still no good
Refresh USB Ports
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  COLFY 22:43 01 Dec 07

Thanks for that. I shall try what you suggest tomorrow. I shall reply later when I have tried your solution. Thanks for answering.

  2neat 09:46 02 Dec 07

I take it you have installed Active Sync free from Microsoft. click here for repair. Good luck!

  bluenote 00:42 05 Dec 07

try the mio forum .Lots of people their to help.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac