Mikomi flash drive not recognised

  jonson23 18:59 25 Aug 07
Locked

I have just bought a Mikomi 2GB flash drive in Argos. My laptop and my work pc both of which use XP recognised the drive as soon as I plugged it into the usb drive and it worked perfectly. However, my home pc, which also uses XP will not recognise it and gives the following message 'one of the usb devices attached to this computer has malfunctioned and Windows does not recognise it'. I have tried the various solutions suggested by the troubleshooter and all to no avail. There also does not appear to be a manufacturers website. Any ideas???

  SANTOS7 19:10 25 Aug 07

click here

follow thread it may help...

  jonson23 21:41 25 Aug 07

thank you Santos but the solutions offered here did not work. Sorry about earlier duplicate posts but inadvertently hit return key initially then could not remove original posts.

  SANTOS7 21:52 25 Aug 07

Not a problem matey..

click here

some other things to try..

  ArthurDents 15:17 25 Oct 09

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac