Microtek ScanMaker 4600 repair

  george 11:07 19 Jul 03
Locked

Following advice from 'Support' that it is necessary to remove two screws to gain access to the underside of the glass for cleaning, I removed two screws (the only ones obvious) and tried to remove the metal plate. A small plug on the circuit board detached itself and reconnection isn't possible as the lead is so short. This made it necessary to unplug the remaining two plugs from their sockets and remove the circuit board, being careful of stray magnetism. I still cannot find a way into the scanner although there is an interesting push button on the side - this seems to do nothing on depressing it. Has anyone an idea as to how I might get into the body of the scanner - and is there an easier way to clean the underside of the glass? Any advice will be most gratefully received.

  george 19:08 21 Jul 03

In c

  george 19:11 21 Jul 03

In case anyone needs the answer, Microtek hides the two fixing screws under the lid's hinges. The lid has to be removed to gain access to those screws and then it takes some firm handling to remove the top to gain access to the underside of the glass. Problem solved.

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Why ecommerce hasn't taken off on social media

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's expensive and powerful…