Microsoft Update Problem

  alB 17:21 16 Jul 07

My Computer is telling me there is an automatic Security Update for Microsoft .NET Framework, Version 1.1 Service Pack 1 (KB928366). For some reason it has downloaded the file but is unable to install, I've updated the Windows installer from the Microsoft website but everytime I start the PC I'm getting the updates are ready to install icon but it will not go in, Any help please ...alB

  Fruit Bat /\0/\ 17:29 16 Jul 07

1. Start - RUN - type sevices.msc press OK
scroll down to Windows
Installer service stop it if it is already running.

2. Open a DOS window and register the following files with command regsvr32

(Replace FILENAME.YYY with the following file names)

3. Unregister and then register msiexec with the commands
c:\winnt\system32\msiexec /unregserver
c:\winnt\system32\msiexec /regserver

4. Open the registry and check the ImagePath under
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer. Does it
point to the correct path? It should be something like:
C:\WINNT\System32\MsiExec.exe /V

5. Reboot the computer and retry the installation

  alB 17:53 16 Jul 07

Thanks for the reply, I'm struggling with your instructions from the DOS window part, The windows installer is stopped, I've checked the registry key without any alterations and it points to C:\WINDOWS\System32\MsiExec.exe /V. ...alB

  birdface 17:54 16 Jul 07

Remove automatic up-date,And download it manually.Or your computer will keep downloading it,When you download it from Microsoft up-dates, Open it first. Make sure that there is a file in there,As all mine say 0 Kb download.Just tick the bottom of them if they are like that, And they wont be shown again.Obviously if there is a file ,Download it and see what happens.A lot of us are waiting for Microsoft to fix it,Just a matter of waiting.

  Fruit Bat /\0/\ 18:02 16 Jul 07

DOS Command prompt (usually under Accessories )

Start -run - type %SystemRoot%\system32\cmd.exe press OK

  alB 16:33 17 Jul 07

Sorry for the length of time in responding, we had a lot of thunder and lightning around last night so decided to switch off, Fruit Bat /\0/\ , I followed your instructions and eventually got it right, unfortunately the update still won't install I've turned off automatic updates for the time being as buteman suggests, would it be wise to remove the .NET Framework 1.1 application all together and re-download it from Microsoft ? ...alB

  Graham. 17:55 17 Jul 07

I asked first click here

  alB 22:33 20 Jul 07

Has anyone found/heard of a solution to this problem ...alB

  brundle 22:46 20 Jul 07

This worked for me on my own PC; click here

For an office PC I use I removed Netframework 1.1 using Add/Remove,rebooted and downloaded the stand-alone executable and installed, then downloaded the update manually and installed it, seemed to solve the issue (the other method might have worked, I decided to try a different method I'd seen on the 'net)
Net Framework 1.1; click here
Update; click here

  alB 09:50 21 Jul 07

Cheers brundle, I used the fix by George J in your first click here, (about half way down) and it worked a treat, all back to normal now, thanks also to others who tried to help, great advice as always ...alB

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac