Memory Stick problem

  antony.dandrea 17:49 30 Jun 09
Locked

Hey guys.
I run Windows Vista Home Premium and use a memory stick which is used on my laptop with this Vista and another computer with XP.

Now there is a problem with the memory stick, but XP and Vista respond differently.

On Vista, AutoPlay doesnt run. When i go to My Computer, the memory stick is there, but when i double click it, a message box comes up saying "H:\ Application not found". But when i right click and click Open it works fine.

On XP, Autoplay Runs. But then does nothing. When i double click it, a box comes up which has a list of programs (like Adobe and Notepad) to open it with, which obviously i cant. But Right click and open makes it work.

I have scanned for virus' and iv used Vista's "Scan and Fix" and everything is fine.

The fact that it works by Right clicking it and pressing Open, but not by double clicking it, makes it more suspicious and difficult to fix.

Thanks for reading and your input.

The Doctor

  DieSse 18:03 30 Jun 09

What do you want to happen??

Do you want it to open in Explorer?

Sounds like you need to set the autoplay settings to do what you want.

  antony.dandrea 18:05 30 Jun 09

i want it to be able to work by double clicking it, instead of the error message coming up. And i want autoplay to actually work. Its nothing to do with setting it up, it is set up. Read it again to see waht comes up.

  lotvic 18:48 30 Jun 09

The_Doctor, you have missed the point -

It is the autoplay settings in Vista and in XP that need to be set up.

Rightclick and choose Properties > Autoplay tab.
and make your choices there.

  antony.dandrea 18:56 30 Jun 09

its nothing to do with the settings. it is set up fine with both of them. Otherwise it would only not work on one of them.
Plus the message "H/: Application not found" doesnt sound like it has anythign to do with autoplay settings

  DieSse 19:29 30 Jun 09

"i want it to be able to work"

But what do you mean - "work" - open in Explorer and display it's contents?

  antony.dandrea 19:32 30 Jun 09

yes. it should do that either automatically, or wen i DOUBLE CLICK.

Currently i have to RIGHT CLICK and CLICK OPEN.

OTHERWISE THE MESSAGE ABOVE APPEARS. Why is this so hard to understand.

  lotvic 21:06 30 Jun 09

Try this experiment to help us troubleshoot your problem.

On the XP machine, with the memory stick already in:

Rightclick My Computer> Explore
rightclick on H:\ and choose Properties > Autoplay tab
In dropdown box choose 'Mixed content'
Put a green dot in 'Select an action to perform'
Click on 'Open folder to view files using Windows Explorer' so that it is highlighted.
click on 'Apply' and then on 'OK'

Close all and Exit back to desktop, using the 'safely remove hardware' first to make sure XP has finished writing take out the memory stick
Count to 10 slowly. Now put the memory stick back in.

It should now autoplay by opening Windows Explorer window and display the contents of the memory stick.
Tell us what happens when you have done the above.

  DieSse 21:26 30 Jun 09

"yes. it should do that either automatically, or wen i DOUBLE CLICK."

With respect that is not exactly what it should do.

It should, depending on the settings, either

Open using what you've set it to open with (which would normally be Explorer, but could have been set to anything either accidentally or some other way).

OR

Run the standard Autoplay program, if set to Autoplay, and ask you what program you want to open it with

OR

Nothing at all if you've not set it to Autoplay.

Double clicking doesn't actually come into any of those scenarios.

If you set it to "Take No Action" - then you open Explorer and see the drive in the folder, then a single-click should open it - if you use My Computer and see the drive on the Contents side, THEN a double-click should open it.

You need to realise that your computer is in front of you, and what you see is obvious to you. We can't see it though and sometimes it's not so obvious what you mean when you say "it should work".

As is said above, if Autoplay actually runs on XP then you should follow the instructions given if you want the drive to open in Explorer.

In Vista I'm not sure what's happening, though I seem to recollect some recent security updates messing with Autoplay - I'll try and find something.

  DieSse 21:34 30 Jun 09

You might like to read this

click here

There has recently been a serious virus outbreak that uses Autoplay on memory sticks in particular to infect a system from a virus that has gotten onto the stick on another system.

The security updates they refer to in the article specifically disable Autoplay (or AutoRun) to stop that happening.

I suspect you may have had the update and something is now not quite right. If your Vista system is set to Auto run and the system isn't doing that, then I would think the a registry setting has become changed or corrupted. Have a look here for a start.

click here

  antony.dandrea 07:07 01 Jul 09

Hey Guys.

I found out why AutoPlay wasn't working.

It was set up fine. However, because i recently installed some software on the Memory Stick, it kind of confused it a bit because it was the installed software that was being detected and AutoPlay doesnt open the Folder in Explorer for Installed Software (by Installed Software, i mean exe files). If that makes sense.

So now i set it to open Explorer with this file type and it works fine now. The problem is that itll also open the Folder if i put a Software CD in the Drive. But oh well.

Once again id like to Thank you all fro ur help and time and sorry for the inpatience :)

The Doctor

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation technologies coming to Siggraph 2017

iPad Pro 12.9 vs Surface Pro 5