Maxtor Diamond 40 ATA 66 not recognised.

  bswollocks69 23:34 29 May 05
Locked

My Maxtor slave has been working ok for a couple of years now. Then became noisy. Now I can see it in the bios and under disk drives in device manager. It shows the master and the Maxtor slave as GENERIC IDE DISK TYPE 47.
But the Maxtor slave is not visable in 'my computer'. Operating system is Windows 98.
Any ideas?

  DieSse 23:39 29 May 05

Download the Maxtor PowerMax diagnostics from their site, and do a test of the drive.

  bswollocks69 23:53 29 May 05

Thanks for that. Did the test, but it did not list the Maxtor drive at the end of the test.
Though it did list a drive as not recognised.
When I highlighted it and pressed F3 the a:/ prompt appeared.

  DieSse 00:07 30 May 05

"Did the test, but it did not list the Maxtor drive at the end of the test"

I'm not sure I understand you - surely you have to select the drive before you do the test?

  DieSse 00:21 30 May 05

This is the procedure - I tried it just to make sure I'd not forgotten!!

Download the program - run the program, which creates a floppy disk.

Reboot your system from the floppy disk

The program runs, and the first thing it does is to try and detect your drive. If it can't then the drive is a real problem.

Switch off the system, at the mains, take the cables off the drive, and plug them back in again.

Redo the test.

If the diagnostic still can't find the drive, it's failed.

  bswollocks69 09:45 30 May 05

DieSse,
Thanks for that.

Here are the results;
primary master- no device found
primary slave- no device found
secondry master- my cd rom drive
secondry slave- no device found

So it is not detecting the master drive either, only the cd rom drive.

What do you think?

  SEASHANTY 10:05 30 May 05

Double click the salve drive in Device Manager and see what other information you can find out from the window which appears and clicking the various tabs.

  DieSse 16:41 30 May 05

What do you think?

I think if the PoweMax diagnostic cannot even detect the drive, then either the drive is defunct (most likely) - the IDE cable or power cable is bad - or the motherboard has a fault.

The final test would be to try the drive in another system, to rule out the less likely possibilities.

  DieSse 16:43 30 May 05

PS - if it's only a couple of years old, it might be covered under warranty. See the Maxtor site for how to check this.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…