Maxthon

I am using Maxthon as my default browser as it was recommended to me as an excellant pop-up blocker. The only problem is is that when I open it it comes up with the Maxthon Start Page rather than the website I want as my 'homepage'. Any ideas how I can rectify this?

Solved it myself!! Should anyone else need to know, click on desired homepage select options>maxthon options>general tab>start page on left>use current.

  zincy 21:51 15 Nov 05

i too use maxthon and find it lot easier to manage compared to IE when opening many windows

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

New Corel ParticleShop plugin now available: 11 new brushes & 6 new brush packs

Apple AirPods review: Apple's beautiful new Bluetooth headphones bring true intelligence to…