Malware query

  Happy37 17:33 28 Aug 10
Locked

MY PC was infected by a virus? or malware titled Fraud Sysguard today.

I ended up stopping everything as I was doing at that moment, and I scanned my system with Spybot S&D and Malwarebytes Anti-Malware.

I think that my PC is now clean, but I now find that some webpages don't load any more.

I get the "page cannot be displayed" message(s), and I also get "connecting to 127.0.0.1" instead of the webpages loading.

So, apart from re-formatting the PC and startng agian from scratch, how do I get the webpages connectivity restored, please?

I might be wrong here - but has the Hosts file been altered in some way by this malware? If yes, then how do I restore a working copy?

If there is anything else that I need to do or know about, please let me know too.

Many thanks - all responses welcome.

Regards

Happy37

  MAJ 17:39 28 Aug 10

The Hosts file is the first thing I would have thought of given your symtoms, Happy37. To check it out, open the Hosts file in notepad and see if any of the web addresses you are having problems with are redirected to the local machine adress of 127.0.0.1. You can install a new version from click here

  Fruit Bat /\0/\ 17:40 28 Aug 10

127.0.0.1 is the internal IP address of EVERY computer. It is a loop-back IP address that points back to your machine (or any machine you happen to be on). It is the same thing as using click here.

Unless you are running a web server on your machine, the response you received is perfectly normal.

It sounds as if your homepage has been hijacked try resetting the home page in IE tools menu Internet Options.

If it won't reset then you are going to have to scan with something like Hijack This.

  MAJ 17:41 28 Aug 10

Lord, my spelling is woeful today.

symtoms = symptoms

  Happy37 18:17 28 Aug 10

@MAJ - thanks for your reply.

I have now loaded a new copy of the HOSTS file from the link you've given.

@Fruit Bat /\0/\

I have also managed to reset the homepage in Internet Explorer back to my default homepage. I have also reset IE back to the default settings.

What I have also found that Firefox works OK for some websites, but IE still keeps on giving me the "page cannot be displayed" message(s), and I also get "connecting to 127.0.0.1" instead of the required webpages loading.

So, what can I try next, please? - is ot time for a format and reinstall of Windows?

Thanks for all of your help so far, it's much appreciated.

Regards

Happy37

  Happy37 18:18 28 Aug 10

*should read it and not ot above...typo.

  Happy37 18:19 28 Aug 10

Should have said that I am typing this now in Firefox.

  birdface 21:37 28 Aug 10

When using internet explorer try going to command prompt and type in ipconfig /flushdns it should tell you DNS cache has been flushed if so reboot the computer and see if it works any better.

  Happy37 20:49 01 Oct 10

All is well now - have since reloaded Windows.

  gazzaho 13:04 02 Oct 10

You may want to consider downloading SpywareBlaster it allows you to create a backup hosts file along with other tools for blocking malicious sites and Active X programs while surfing.

This thread is now locked and can not be replied to.

Surface Pro 5 News - release date, UK price, features, specs

Microsoft Surface Studio hands-on review: the iMac killer is here

Best Mac antivirus 2017