Making folders private

  Rhuddlan 00:18 04 Feb 04
Locked

In order to make many folders private in the hard disk, like Program Files and Windows etc, I was reading in the latest XP Mag that I need to go into safe mode to do this, so when in safe mode, I right clicked on the Program Files folder, click on the secruity tab and unchecked the boxes for the limited account, and restarted, but the limited account can still gain access to these folders, any ideas?

  vinnyo123 04:19 04 Feb 04

did ya try control panel>folder options>view>put a tic do not show hidden folders or files>"hit apply"

then on folder that you want to hide right click>
properties>attributes tic hidden "hit apply"

PS don't forget where you hide it or the folders name.Test on desktop first ..


might do the tric

  temp003 05:46 04 Feb 04

Are you using XP Pro or XP Home?

  Rhuddlan 18:52 04 Feb 04

Using XP Home

  temp003 01:26 05 Feb 04

I'm not sure to what extent XP Home can change these permissions settings and make them effective. The following suggestions may or may not apply to Home. But since the check boxes are available when you boot into Safe Mode, resumably it can do it.

In XP Home, Simple File Sharing is always enabled. All local users (including Limited User) have access to the local drives (your C). The only folders which can be made private are those under the Documents and Settings profile folders.

NTFS permissions under the Security tab are a different tier of access control. Assuming you can change individual files permissions in XP Home, the problem you are having may be due to the parent folder permissions. "Allow" permissions are cumulative. The Program Files folder is under the parent folder C. By default, the Limited User has access to the C parent folder, so disallowing specific permissions in relation to the Program Folders will not prevent the Limited User from having access to anything in the C parent folder.

Try a couple of things. Instead of unchecking the boxes under the Allow column, try ticking the corresponding boxes in the Deny column. This may override the "Allow" permissions inherited from the parent folder.

See if you have an item called "Inherit from parent the permissions entries that apply to child objects ..." If you do, and if it has been ticked, untick it.

After making these changes, if applicable, tick OK.

Then open Windows Explorer (Start, All programs, Accesories, Windows Explorer). Navigate to the Program Files folder. Right click, Properties, Security, Advanced, and see if you have the Effective Permissions tab. If you do, click Select, and enter the name of the user account or Limited User group to see the cumulative effect of the changes you have made, and whether the changes you have made achieve what you want to do. If you don't have this tab, skip this step.

If it seems OK, restart, log on to a limited user and try it out.

This thread is now locked and can not be replied to.

Hands-on: Samsung Galaxy S8 review

1995-2015: How technology has changed the world in 20 years

Samsung's beautifully designed Galaxy S8 makes for better VR experiences too

47 iPhone camera tips to help you take better photos