A logical disk has a dirty bit set

  wrg 19:33 05 Oct 07
Locked

I have ran a reliability and performance check on my lappie & am getting the above error message. Can anyone tell me what it is,and also getting "a service is reported as having an unexpected error code with a code not equal to 0 or 1077". If I click this link it takes me to MS website but cannot understand it.

Thanks

wrg

  johndrew 20:20 05 Oct 07

This will tell you more click here


You can check to see if your drive is definitely flagged by opening up a CLI Window (Start menu -> Select Run -> type in CMD)

Now type in the following:

FSUTIL DIRTY QUERY C: (followed by the enter key)

(assuming that C: is your boot drive)

If it tells you that your drive is dirty then...

Go back to the CLI window and type in the following

CHKNTFS /X C: (followed by the enter key) - This will stop the disk check on the next reboot

Now reboot your computer: let it reboot and open up another CLI - type in the following:

CHKDSK /F /R C: (followed by the enter key) - Let is scan and check your computer fully

Once it has done so type in the following again as in the first step

FSUTIL DIRTY QUERY C:

The drive bit will be set to clean again


Be aware the checking can take some time so ensure you are on mains with no shut down set for period of non-use. DO NOT interrupt the process as you could easily make things worse.

  wrg 20:27 05 Oct 07

johndrew

Thanks so much for your reply. Followed step 1 but tells me I need adminstrator priveleges. I am running vista basic

  wrg 09:17 06 Oct 07

Done that get a message saying not dirty

  wrg 09:48 06 Oct 07

johndrew

did another performance check this morning and not getting that error message any more. Bizzare

  johndrew 10:55 06 Oct 07

Find this very strange, but glad the problem has gone. Have you carried out a virus scan in the meantime?

  wrg 11:24 06 Oct 07

not yet. Trying to solve another problem with an abnormally stopped system service. Trawling the net trying to find how to solve it.
Its a UPnP device host error, any ideas?

  johndrew 12:25 07 Oct 07

Sorry can`t help there. Perhaps if you start a new thread with full details of the problem you will get a good response - plenty of varied experience and knowledge on this forum.

  wrg 16:11 07 Oct 07

johndrew. Thanks for you input. Did a clean install in the end. I think the problem related to some software that I loaded on my system. It was Sony Handycam S/W. When I tried to use it I was getting errors saying I could not use USB. I tried to uninstall it but it would not fully uninstall. Further investigation pointed to a problem occuring with USB being stopped at start up.

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Framestore’s haunting post-WWII title sequence for new BBC series SS-GB

How to install MacOS Sierra on an older Mac: Get Sierra running on Macs & MacBooks from before 2009