Linux/time/incorrect on emails

  grumpy-git 23:56 12 Apr 09

Getting on well with Cnm lifestyle 7" minibook, but have a problem with date that shows on e-mails.

If I send an e-mail from my Vista pc, it appears on the minibook showing a time of 1 hour less than the time originally sent. Example 23.40 actually shows as 22.40 and when I open the e-mail it shows a time of 23.40 +0100.

If I send an e-mail from the minibook to the Vista pc it appears to have the correct time in the list of e-mails, but when the e-mail is opened it shows the time +1 hour.

I've done much searching on this, also tried other forums that deal with Linux & mini pcs but no luck so far.

If anybody knows about Linux and can explain how to fix this, I would be grateful. I have tried changing time & zone from London/Europe to other setting, but that doesn't seem to make any difference.


  Poitier 11:18 13 Apr 09

You say that you have done much searching but have you tried the 'New to Linux' forum.
click here

  grumpy-git 19:47 15 Apr 09

Had a look at that Linux forum - thanks for posting the link.

Even posted "my problem" there, had a couple of replies but still not close to a solution.

  LastChip 21:53 15 Apr 09

Are you sure it's not Vista the problem, rather than Linux?

If you send yourself an email back to your Vista machine, (in other words, send it from the Vista machine back to itself) is it the correct time or not?

  grumpy-git 22:08 15 Apr 09


Thanks, it's not Vista that is the problem. This explains it - Yahoogroup messages relating to an event at say 18.25 are posted by other people at 18.30. On the Linux machine they appear to have been posted at 17.30 and within the e-mail the time is 17.30 +0000 but on the Vista machine they show a correct time of 18.30.

One suggestion is tzselect, once I know how to run it! Shows the limit of my knowledge of Linux.

Will post the solution here, once I know what it is.

  LastChip 13:51 16 Apr 09

Stands for Tome Zone Select and is a command line utility.

Just open up a terminal, type tzselect and hit enter. You will then be given a menu to work through in order to set up the time base on the computer. Just remember to hit "Enter", each time you make a selection.

The first selection is your region and I assume your in Europe somewhere, so hit 8 and Enter (and so on.

  LastChip 13:52 16 Apr 09

Time Zone Select!

  grumpy-git 16:43 16 Apr 09


Probably being a bit thick here, I have installed xterm which is getting me somewhere.

Typing date - I get:-
Thu Apr 16 16:36:58 UTC 2009

typing tzselect I get an error line, 65 syntax error "do" unexpected (expecting")")

Am I typing tzselect in the wrong place? (probably, knowing me)

  LastChip 17:22 16 Apr 09

Normally, there is a built in shell (terminal) such as bash and almost certainly, there is a shell like structure running underneath the GUI (desktop).

The trouble is, manufacturers will "fiddle" with existing operating systems, rather than leave them intact and as I haven't come across your particular variety, I can only guess what they have done.

But you could try this:

Forget xterm for the moment and boot into the system normally. When it's up and running, try hitting; Ctrl+Alt+F2 and see if that takes you to a shell, If it does, try the command again. Ctrl+Alt+F1 should bring you back to your GUI.

I don't want to confuse you, but you can run multiple shells by using Ctrl+Alt+F2, F3, F4 etc. F1, will invaribly always bring you back to a GUI.

It is possible on your system, you don't need Ctrl. You may only need to press Alt+F2.

Also remember, (unlike Windows), all commands in Linux are case sensitive.

Let me know how you get on.

  grumpy-git 17:58 16 Apr 09

Thanks again.

I seem to be going round in circles a bit.
Ctrl+Alt+whatever is somewhere I was experimenting with yesterday. I didn't get very far, which is why I installed xterm.

Just tried it again. Alt+F2 does return me to desktop. Ctrl+Alt+F1 gets me a blank screen, which doesn't seem to do much. Ctrl+Alt+F3 gives me a screen asking me to press enter to activate, then I log in with root.
ls just gives me Mail (in blue) I remember seeing directories when typing ls on another screen, probably xterm (yes, it does)

Still get nothing useful when I type in tzselect

  LastChip 23:50 16 Apr 09

It appears your computer runs a Debian based operating system and uses a MIPS processor.

As such, you should be able to go to your xterm, which is an approved terminal and run the following:

apt-get update


and then:

apt-get upgrade

Can you try that please and let me know the result.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…