linux booting really slowly

  Turnerminator 19:28 15 Aug 04
Locked

Hi

I am running dual os, windows xp pro and suse linux pro 9.1.

I am however experiencing some problems. Windows runs fine, but linux after the boot loader seems to lock up. It reaches the loading screen, and the hard drive does not seem to be active for 5 minutes, then it flies through the rest of the processes, at what i expect to be normal linux speed, then loads the login screen.

Are there any suggestions about how to cut the loading time? I have tried turning acpi off, but it does nothing.

I would appreciate any help, thanks.

  Goycoolea 00:48 16 Aug 04

Do you see any messages, or is SuSE doing that annoying thing distros do these days and hiding messages from you on boot?

Booting _anything_ doesn't hang for five minutes doing nothing - if you see messages, tell us where it hangs and what it says. Problem with hostname resolution is my guess, I've seen that slow down boot before. If you see no messages, fix it:

Become root, edit /boot/grub/menu.lst (the config file for GRUB which I guess you are using) and change the part that says:

splash=silent

to:

splash=native

Cheeers,

Dennis

  Chegs ® 04:03 16 Aug 04

More to take onboard.Thanks Dennis. :-)

  Turnerminator 11:34 16 Aug 04

well, i cant see the details of the boot, until it actually becomes active again, and then it flies through it so i cant see what it was hanging on. I will try to look on the boot log and get back to you.

  dth 12:41 16 Aug 04

How have you set Suse to start? Are you using the Linux bootlader GRUB - and choosing which system to start each time? Or are you using instead a boot floppy to start Suse?

  Turnerminator 12:44 16 Aug 04

I am using boot grub loader, the default one, and selecting each time.

  dth 13:07 16 Aug 04

It sounds like Suse is trying to find something on boot-up. When Grub starts, and you select suse, can you press f2 so the boot up steps are shown to see if you can see anything obvious that is causing the problem.

Another thing to look at is to by pass the Grub settings that you have on your p/c by using a boot floppy. You make one of these in yast. Am at work now (with win 98) but from memory it is in the group third down - top option to the right. Just change the settings (boot location) to floppy disc and press to save.

Then if you re-start your p/c with the bios settings set to boot from the floppy disc first - we can find out whether it is the Grub settings on your p/c that are at fault.

  dth 19:43 16 Aug 04

At home now. System / yast / system / bootloader configuration - then change the bootloader location to: /dev/fdo

If you click on the Misc tab - there is an option to view the start up log

  Turnerminator 11:16 17 Aug 04

OK, i will try that, see if it works any faster.

  dth 17:29 17 Aug 04

just another thought - do you have any jazzy things plugged into your p/c like a digital camera? If so try starting Suse with anything like that unplugged to see if it makes a difference

  Turnerminator 22:14 17 Aug 04

nothing jazzy, just a mouse, keyboard and some cheapey speakers. got a pci card and graphics card to, wich are configed in windows, but not linux.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

Best Christmas Agency Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…