limited or no internet

  harps1h 08:23 AM 22 Aug 11

I have a dlink modem/router through which I connect this system via ethernet. However, I revived an old computer yesterday for the sole purpose of using it as a method of running admin tools whilst gaming. This connection is wireless, using a belkin G pci adapter. This is where I get the message, and having tried various methods including a winsock fix, it just will not connect to the internet.

Has anybody any ideas, I don't care if they are ones I have seen suggest them so I can say whether or not I have tried them. Something inside me says it maybe the router stopping internet access, but what it is I am not too .

The OS is windows XP Service pack 3

  mgmcc 08:46 AM 22 Aug 11

I assume the actual message is "Limited or No Connectivity"? This means that the network adapter has failed to get its proper IP address by DHCP from the router and Windows has defaulted to allocating a 169.254.x.x APIPA address (Automatic Private IP Addressing). This address won't let you connect to the router or the internet.

As you're using a wireless connection, have you actually Connected to the wireless network, i.e. checked for Available Wireless Networks, selected the one whose SSID matches that of your router and selected the option to Connect to it? You'll be prompted to enter any WEP/WPA/WPA2 encryption key and should then connect and get the IP address and internet access.

  harps1h 19:27 PM 22 Aug 11

The windows tool is telling me I am connected to the network, but when I try to access the internet I am stopped. The Belikn utility also tells me I am connected, but you are right about the 169.254 address. It shows that as the address of the connection.

  harps1h 19:34 PM 22 Aug 11

here is the results of my ipconfig/all

Microsoft Windows XP [Version 5.1.2600] (C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Harpur>ipconfig/all

Windows IP Configuration

    Host Name . . . . . . . . . . . . : harps-991e171b4
    Primary Dns Suffix  . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Belkin 802.11g Network Adapter
    Physical Address. . . . . . . . . : 00-11-50-3D-6A-1D
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :
  mgmcc 21:41 PM 22 Aug 11

I think it still comes back to your not having Connected properly to the wireless network (router).

Are you using Windows' own "Wireless Zero Configuration" to connect, or third-party software provided with the WiFi adapter? My preference with XP is to use WZC, but some third-party software takes back control of the wireless networking when the PC is booted and the only way to resolve that is to remove the software.

  harps1h 10:40 AM 26 Aug 11

you were right. I decided to go back to basics and looked at the installation. Here I found my mistake.........there was one character wrong in my hex code. A basic and fundamental mistake I know, but one which is made commonly. So problem solved and thank you for your input.


This thread is now locked and can not be replied to.

Sony Xperia Z5 review: Hands-on with the phone which the Z3+ should have been

1995-2015: How technology has changed the world in 20 years

Get your photos turned into illos by some of the world’s best artists

What to expect at the September Apple event: Apple announces 9 September event, sends out invites