Li Ion battery won't chage

  Pooter45 22:45 21 Feb 07
Locked

I have a 9 month old Li Ion battery with my laptop (both were new 9 months ago).

I dilligently let it run down to zero once a month via the bios screen and then charge it to full.

2 weeks ago it was fine, but I did the usual and then went to start it up.

It seems the battery memory (or whatever there is) decided that the full charge is now 0%, not 100%, as far as I can tell from the utility that manages the power settings and so on. The battery 'charges' in a minute and lasts about 30 seconds before going kaput.

I discovered a utility in the bios that suggested it might reset the memory (I'm not a 'techie', btw) and tried it. Several times.

I rang the manufacturer (Evesham) to be told the warranty on the batter is 3 months (for an unexplained reason) and to be given some advice (to possibly discharge a build up of energy) which didn't work.

Is there anything to do to get the battery back?

Is there any reason why Asus, who made the battery I believe, shouldn't replace the thing?

I'm using the pc in mainland Europe, but I've used a previous Evesham all over the world without any trouble, so I can't see why this one suddenly went on the blink.

Any suggestions are appreciated.

Thank you.

  woodchip 22:48 21 Feb 07

If I was you I would try Trading standards, See what they have to say about twelve months. I would say it comes under not fit for the purpose

  Ho-Lin-Sok 23:55 21 Feb 07

Sometimes putting them in the deepfreeze works. 24hours @-20 then let them thaw without help.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac