LG Monitor F900P

Purchased a monitor as part of a package from Evesham.Within 2 days the monitor developed a fault. I simply moved it and the picture disappeared not to be seen again. Error message indicated NO SIGNAL CHECK SIGNAL CABLE. Did all that even bought a spare cable didn`t solve problem. Anyway those nice guys at Evesham said bring it back to shop we will replace it.New monitor worked perfectly from mid Feb until lastnight when I decided to tilt the monitor and off it went again. Same problem checked all the cables,connections etc same error message as before. Hooked up old monitor using same cables it works therefore I assume problem is the LG monitor. LG going to replace it within 48 hours.

Is this unlucky same fault has ocurred twice or is there some sort of fault with this monitor. Never ever had problem like this before with this old PB monitor.

Any ideas as to problem is it something I did will it happen a third time .

Any thoughts ?

  professor 20:28 02 Apr 03

i had that problem once turned out my PSU wasnt beefy enough there are other things as to why it went wrong but its a very long list

prof

  cheapskate2k 21:04 02 Apr 03

Ive got the same monitor and havent had any problems with it. Pleased to see that they replaced the monitor without any problems though! Hope the next one turns up ok and is problem free.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…