Lexmark X85 and usb hub

  ElephantRhino 17:08 22 Sep 04
Locked

Does anyone have any experience of connecting Lexmark X85 via a usb hub? I want to add a switch to my system to connect both printer and PDA cradle. Lexmark support say they "cannot guarantee that the printer will work properly" but are they just taking the manufacturers 'we can't support that' stance?

  Wak 18:26 22 Sep 04

Reading previous threads I gather that some printers need more power than a USB hub can supply and therefore it is best to plug the printer directly in to the usb port and use the Hub for other things which do not need as much power to operate.
It could be a case of try it and see!!!

  johnnyrocker 18:30 22 Sep 04

from my experience of lexmarks and usb connections it appears that the lexmark hogs all the usb ports and so disabling any other connection and in general the solution has been to re boot with printer disconnected in order to enable other usb use.

johnny.

  ElephantRhino 10:24 23 Sep 04

I was worried someone might say that as the whole point of the hub is to avoid re-connecting all the time. Thanks for guidance.

  johnnyrocker 10:31 23 Sep 04

a poss solution might be to get updated drivers from the lexmark website (not your cd ones)uninststall lexmark and what ever other device the conflict is with and re install lexmark then the other device.

johnny.

  iarno 23:50 23 Sep 04

Have I got the wrong end of the problem? I use Lexmark X83 and have just installed a Lexmark X85 on my daughters comp. she is running Win XP and mine is Win Me. Both machines have their own power suply from electrical outlet from which you set the machine up, you then install the software and connect the USB cable when prompted. I have never encountered a problem (as yet). I also have an HP printer installed as a backup (when running low on ink in the X83). My USB connection is through a 4 port hub all 4 ports in use.

I.

  ElephantRhino 11:12 24 Sep 04

Does this mean that you have the Lexmark and other devices permanently connected through the hub without problems? And is your hub separately powered?

  iarno 21:59 24 Sep 04

sorry not to get back to you befor now. I only go on line evenings.

Yes i do have lexmark and other devices connected permanently through the hub.and i haven't had problems as yet, been running like that for 14 months.

I have a Belkin USB 4 port hub which is separately powered the hub model is F5U021.

does this help in anyway.

I.

  iarno 21:32 03 Oct 04

Hi, it's been over a week now since you posted here and no response from you.

have you resolved your problem.

If so can you let us know how you solved it so that anyone else with the same problem may be helped.

regards I.

  ElephantRhino 10:04 04 Oct 04

Hi Iarno - I suspect that your setup will work for me but I haven't yet bought a similar hub to prove it. I do wonder if a powered hub makes the difference here.

  OwenLotts 12:20 04 Oct 04

Have seen many Lexmark (and Epsons) not working when plugged into hubs even powered ones. Apparently it interferes with the two way communication! My Canons work on a hub marvellously by the way!

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…