Lenovo IdeaPad Z575 - HDMI to TV sound did work, but now it doesn't!

  kissifa 12:00 PM 18 Nov 12
Locked

Hello there,

I have a Windows 7 Home Premium Lenovo IdeaPad Z575. I connected it to my 37" lcd TV (Acoustic Solutions) via a HDMI cable and the laptop detected the new display using the AMD Vision Engine Control Centre, and it worked perfectly with video and sound, no problem. Then one morning, I turned on the laptop, and the TV showed the extended desktop as usual, but there was no sound!

Many internet searches on this topic later and I have ensured that the audio was set to the AMD High Definition Audio Device as Default, I have tried the most up to date AMD graphics and audio drivers from both the AMD and Lenovo sites (Catalyst versions 12.8), and rolled back to older video and audio graphics as I read some people saying the latest drivers were the problem (Catalyst 12.6 - should I go back further??). I even tried a BIOS update and a chipset utility download from Lenovo. Nothing has brought back the sound.

I don't know if it's a related problem, but I also cannot, despite all this, find the SM Bus Controller driver either, despite a chipset install. Argh.

My laptop identifies the PC as a Generic PnP Monitor in Device Manager, and an AMD High Definition Audio Device if I look at the volume controls. The TV recognises the connection as HDMI and as soon as I plug in the HDMI cable my desktop appears on the TV, and the volume icon switches from speakers to the AMD HDMI output.

The only difference all my installing etc. seems to have made is that even if I tell my laptop to ignore the TV and not use it, it just re-detects and activates it, but still no sound.

Any help would be very much appreciated. What a frustration after it was working so well!

  northumbria61 12:52 PM 18 Nov 12

Have you installed any Windows Updates between the time that it was working and now? If so remove/uninstall recent updates or try a System Restore to a time just before the problem occurred.

  kissifa 14:00 PM 18 Nov 12

Thank you for the new idea - I tried a System Restore back to five days ago when it was working fine, but no change, except oddly instead of filling the whole TV, my desktop now only fills the centre, at the same size as my laptop desktop. Weird.

So no luck, I'm afraid. :(

  Fruit Bat /\0/\ 17:55 PM 18 Nov 12
  1. Right-click the Volume icon by the time in the lower-right corner.

  2. Click Playback Devices .

    The Sound window opens.

  3. On the Playback tab, click one of the following audio output device that is listed:

    Digital Output Device (HDMI)

    Realtek HDMI Output

    NVIDIA HDMI Output

    ATI HDMI Output

    ATI HDMI Output selection

  4. Click Set Default .

  5. Click Apply .

    If you used Digital Output Device (HDMI) , click OK to close the window. This completes the steps to activate HDMI sound.

    If you used Realtek HDMI Output , continue with Step 6.

  6. Double-click Realtek HDMI Output .

The Realtek Digital Output Properties window opens. Click the Supported Formats tab. Place a check in the 48.0 KHz check box, and make sure that there are no checks in the Dolby Digital check box and all other check boxes.

  kissifa 18:43 PM 18 Nov 12

Thank you for responding, but unfortunately I already have the device set to Default, and it is set to 48 khz DVD quality in its properties. :(

  Fruit Bat /\0/\ 19:08 PM 18 Nov 12

So you have the Realtek

Check in device mnagee that there are no exclmation marks against the realtk drivers- may even be worth updating them.

  kissifa 20:17 PM 18 Nov 12

Have downloaded the latest RealTek audio driver (IN1AUD17WW5.exe) from Lenovo.com - no luck. :(

  Fruit Bat /\0/\ 20:19 PM 18 Nov 12

Have you tried another HMDI cable?

Is there an input setting on the TV you need to change?

  rdave13 21:04 PM 18 Nov 12

This audio codec/driver works for win 7 and 8 though my gpu is Nvidia. http://downloads.guru3d.com/Realtek-HD-Audio-2.57-audio-driver-download-2672.html

In 'playback devices' if you see something with a code to it, it could possibly be the TV. Try setting as default to see if you get sound if the greyed out area shows 'Ready' when you connect the HDMI cable. Same as Fruit Bat /\0/\ 's advice really but try the codec for HD Realtek first.

  kissifa 19:45 PM 20 Nov 12

The HDMI cable was new out of the box and worked perfectly for nearly a week before the sound issue came up, so I doubt/hope it isn't a cable issue.

I've tried the Realtek driver, and ensured the TV volume is up, and have checked the TV's menus.

I'm starting to think I probably just have to wait till a new Windows or driver update rolls along and undoes whatever damage the first one did. :(

Advertisement

This thread is now locked and can not be replied to.

Sony Xperia Z5 review: Hands-on with the phone which the Z3+ should have been

1995-2015: How technology has changed the world in 20 years

Get your photos turned into illos by some of the world’s best artists

What to expect at the September Apple event: Apple announces 9 September event, sends out invites