Laptop Wont Boot

  Kilty 10:42 30 Apr 10
Locked

I have an Advent 6651 and I am unable to get it to boot. I turn it on, the power light comes on, but nothing else, no fan, no screen. After a minute it restarts, with the same effect.

I have removed the battery and unplugged the power, pressed the on button for a minute and then tried again, with no change. I have also reseated the RAM and unplugged the HDD and plugged it back in again.

Has anyone any more suggesstions? Thanks in advance for any help given.

  woodchip 10:45 30 Apr 10

Did you just try starting on mains only. keep tapping F8 as it starts then either safe mode, or last known good configuration

  Kilty 10:50 30 Apr 10

Thanks for your reply. I had tried that, but it had no effect.

  woodchip 10:51 30 Apr 10

Will it go into BIOS screen?

  Kilty 11:02 30 Apr 10

No, screen stays black and the fan does not come on either.

Thanks again for reply and your help so far.

  woodchip 11:02 30 Apr 10

If it will not boot to BIOS with Hard Drive in. Try booting it with it removed. If it still does not go to BIOS, you've got problems

  woodchip 11:08 30 Apr 10

Have you checked the Charger to make sure its working? as it have run the battery down also

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced