Laptop Speakers no longer work

  wee eddie 14:12 03 Jan 07
Locked

I think the cause was a driver I downloaded at Windows Update suggestion.

If I look at Control Panel > Sounds > Audio or Voice it says "Modem #1 Line Playback" in all the boxes rather than the Sound Systems name which it says on my PC.

I cannot use "System Restore" as I have done quite a lot of updating of software since that happened, including clearing the Recycle Bin, the Temp Internet Files and Defragging the drive.

Where do I find the Drivers and how do I enable them?

  Jackcoms 14:23 03 Jan 07

In my Sound and Audio Device Properties menu the various drop-down boxes give me a range of options to choose for sound playback. Doesn't yours?

Have you also checked in Volume Control that nothing's muted?

  wee eddie 16:30 03 Jan 07

When I got to the List of items there is a black ! in a yellow circle, by the "C-Media AC97 Audio Device". When I click on it I get.

"This device cannot start(Code 10)"

Googling seems to suggest that I need to update the drivers which was the probable cause of the problem. Maybe they haven't installed properly.

Back to the Wizard and Double click the device. having tried to install new drivers I gave up and started on other options. Eventually I chose "Roll back to the previously installed Drivers" and it worked. Crossed fingers

  Stuartli 17:08 03 Jan 07

As Jackoms correctly points out, it would have required the onboard sound device being configured as the Default rather than the modem in Sound and Audio Devices (Audio and Voice tabs).

The latest drivers for C-Media sound devices can be found at:

click here

  wee eddie 17:25 03 Jan 07

The rolled back drivers that worked are for a
SiS 7012Wave

and according to Belarc a SiS 7012 Audio Driver

Don't know why M$ Update recommended that I download the other drivers!

  Stuartli 17:59 03 Jan 07

That is interesting, but WindowsUpdate's drivers updates are notorious, in any case, for often being well behind the latest versions.

  wee eddie 18:17 03 Jan 07

"C-Media AC97 Audio Device".

I took it on trust that that was what I needed but I don't appear to have this device at all.

As I rarely use the Laptops speakers I did not notice that anything was amiss for quite a while. I had updated virtually everything else which is why I could not use a System Restore point.

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…