Laptop : Local Only

  xerty 19:45 11 Sep 10
Locked

Hi all,
Trying to fix a friends laptop (Dell Inspiron 1545) which stopped connecting to the net.
He was using an O2 dongle. I've tried it with the dongle, through the built-in wireless and direct cable connection (the connector LED does not light up either) to my sky router to no avail.
When I hover the mouse over the connection icon in the system tray it states "Currently connected to: skyxx Access: Local Only).
I've tried updating the drivers for the wireless card (Dell Wireless 1397 WLAN Mini-Card) without it making any difference.
Also I have noticed that in the Device Manager there is a problematic device. It has the !warning in yellow next to it and is a Network Adaptor isatap.{xxxxxxx}. I have looked into this and followed some advice at click here... but they all require active net access :(
I have even tried uninstalling the device but it never gets uninstalled - windows just sits there trying to uninstall it.
I've also seen mention of DHCP. The /ipconfig all shows DHCP is enabled. I have checked and the "DHCP Client" service is running. I have checked through the Network and Sharing Center/Manage network connection and both IPv4 and IPv6 are enabled in the Wireless Network Connection Properties and the Local Area Connection Propeties (Marvell Yukon 88E8040 PCI-E Fast Ethernet Controller). Here is the listing from ipconfig /all (after this list is a whole load of tunnel adapters, about 100) :
Windows IP Configuration

Host Name . . . . . . . . . . .: ANDERW-PC
Primary Dns Suffix . . . . . . .:
Node Type . . . . . . . . . . .: Hybrid
IP Routing Enabled . . . . . . .: No
WINS Proxy Enabled . . . . . . .: No
DNS Suffix Search Lst . . . . .: home

Wireless LAN adapter Wireless Network Connection:

Media State . . . . . . . . . .: Media Disconnected
Connection-specific DNS Suffix .: home
Description . . . . . . . . . .: Dell Wireless 1397 WLAN Mini-Card
Physical Address . . . . . . . .: 00-23-4D-CB-8D-8B
DHCP Enable . . . . . . . . . .: Yes
Autoconfiguration Enabled . . .: Yes

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix .: home
Description . . . . . . . . . .: Marvell Yukon 88E8040 PCI-E Fast Ethernet Controller
Physical Address . . . . . . . .: 00-23-AE-15-CF-84
DHCP Enable . . . . . . . . . .: Yes
Autoconfiguration Enabled . . .: Yes
Link-local IPv6 Address . . . .: fe80::305b:18e7:ceb8:18a4%11(Preferred)
IPv4 Address . . . . . . . . . .: 192.168.0.3(Preferred)
Subnet Mask . . . . . . . . . .: 255.255.255.0
Lease Obtained . . . . . . . . .: 10 September 2010 01:22:45
Lease Expires . . . . . . . . .: 11 September 2010 01:22:44
Default Gateway . . . . . . . .: 192.168.0.1
DNS Servers . . . . . . . . . .: 192.168.0.1
NetBIOS over Tcpip . . . . . . .: Enabled

I've run MalwareBytes and it found a few nasties (MyWebSearch), but this has not resolved anything.

Hopefully some of that info will allow someone to come up with some ideas for me to try.
Thanks,
xerty.

  Fruit Bat /\0/\ 21:02 11 Sep 10

Ignore Network adaptor problem click here

Is the router mac address filtering out the del?

  xerty 23:03 11 Sep 10

Agree that microsoft arer saying to just ignore the problem as I read it at the link I posted above.

<Is the router mac address filtering out the del?>
Sorry, don't understand the question.
Ah, do you mean is the router set up to ignore the Dell ?
I'll check when I get home in the morning (at work now), though I can't see that being the case - but anything is possible ;o)

  xerty 23:05 11 Sep 10

Also, I have tried two other laptops (my own, and another one I was sorting for a friend which has now gone back to him) and they have had no trouble with the wireless to sky router. I will try mine via the cable in the morning just to make sure everything is ok with that connection.

  woodchip 23:08 11 Sep 10

I thought that o2 dongle, did not need a router. I thought it connected to the Mobil Network. Why do you need to connect it to the router that's for WiFi

  xerty 07:06 12 Sep 10

I realise now that I do not use MAC address filtering (have checked the router and could not find any other settings of note that could be a problem).
I have tried my laptop with the cable to the sky router and that laptop has no problems.

  xerty 07:09 12 Sep 10

Yes, the O2 dongle does not need a router. But as this was not working I thought I would try the other options available to me - wireless and direct cable to router, though these options are not available to the laptop owner. Unfortunately none of these options work either which has left me rather stumped :O(

  Fruit Bat /\0/\ 10:44 12 Sep 10

As it connects to the router

Try disabling the firewall to see if you can get internet access.

  xerty 18:29 12 Sep 10

The Dell does not connect to the router - my laptop connects to the laptop. Which confirms that there is something wrong with the Dell.

  woodchip 22:11 12 Sep 10

Have you created a Network Connection using the Wizard in Control Panel?

  xerty 22:15 12 Sep 10

I did try the Dell with the firewall off just to see - no difference.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…