Laptop HDMI to LCD TV HDMI but no sound!

  cthooli 22:49 25 Mar 09
Locked

Hi all, recently bought a LCD TV with several HDMI inputs.

My laptop has an HDMI output so naturally thought they would work well together!

Well i can easily get my laptop to display on the tv, not a problem there, however all sound is still coming out of the laptop speakers. I was under the impression that HDMI carries audio also?

Right clicking on the Speaker icon and selecting playback devices, it lists the speakers and HDMI but even setting the HDMI to default the sound still registers out of the speakers.

How do i get the sound going through my tv?

Cheers

  Stuartli 22:59 25 Mar 09

HDMI does carry audio as well as video.

Do you have to select HDMI input on your TV menu (most likely via the remote control)?

  cthooli 23:02 25 Mar 09

Yep off the menu there are three HDMI options, i select the one that i've plugged the laptop into and hey presto, the pictures on the screen!

But the sounds on the laptop

  woodchip 23:03 25 Mar 09

You need a Cable from Speaker or Ear socket on Laptop to Audio in on TV

  cthooli 23:09 25 Mar 09

That would be the case if i was using the S-Video cable but i'm positive HDMI does carry both.

For instance you'd simply use an HDMI cable to connect an Xbox to a TV wouldnt you? And would carry both picture and audio. No need for a seperate audio cable?

I'm guessing there is some setting in windows i'm missing where i can tell it to out put the audio via the HDMI port rather than the speakers - i just cant find it!

  BRYNIT 23:11 25 Mar 09

I think you need to go to Control panel open sound/Audio manager and select the HMDI or Digital output as default.

  eedcam 05:46 26 Mar 09

click here= Loads with similar prob and As Bryni sid setting as default perhaps

  woodchip 09:53 26 Mar 09

You have to have the right cable for HDMI sound, the differ click here
click here
Look through this click here=

  bazb 10:17 26 Mar 09

If using Vista

Control Panel>
Hardware and Sound>
In sound: Change System Sound>
Playback>
Digital output>
Set Default>
Apply.

Just as Brynit said above.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Here's what should be coming to Adobe Project Felix in 2017

Apple AirPods review: Apple's beautiful new Bluetooth headphones bring true intelligence to…