Laptop freezes with wireless adapter installed

  Gaz W 18:28 23 May 06


I've just bought a clearance Evesham laptop via their auctions on eBay. I purchased a wireless adapter (Safecom) to go with this. Everything is fine; the wireless adapter works fine, but when the wireless adapter is installed, the computer will freeze for one second every so often (maybe every minute or something, maybe longer than a minute). This becomes very annoying when I'm listening to music, because it causes the music to stop for 1-2 seconds.

The laptop is an Athlon 64 3000+, 512MB RAM (shared graphics), Windows XP Pro. The wireless adapter installed is a Safecom SWLCT-54125. I have narrowed it down to the wireless adapter because it only seems to happen when that is installed. It played a 12 minute song flawlessly without the wireless adapter.

By the way, the laptop is connected to external speakers - I wouldn't dream of using it with the built-in ones!

Also, I should maybe point out that when I add or remove the wireless adapter, a slight "pop" noise comes from the speakers.

I have already checked the IRQs used by the wireless adapter and the onboard AC'97 audio and there are no conflicts on either device.

Anyone got an idea what the best thing to do now might be?



This thread is now locked and can not be replied to.

Apple Event live stream | Apple October Event live blog: Watch Apple unveil new MacBook Pro, new…

1995-2015: How technology has changed the world in 20 years

Lida designs a cross-stitch email sent to thousands of Ikea Family members

Apple Watch 2 review | Apple Watch Series 2 review: Faster performance, a brighter screen, water-ret…