Laptop dvd rw problem

  wky 14:32 01 Aug 06
Locked

Hi, own a HP NX6125 laptop and the dvd rw drive on it is a mat*!@:a dvdrw 9, I use sonic record now to record dvds but for the past few months it takes over an hour to record a standard dvd-r 4.7gb. When the burning starts it goes quite fast and a few percent is done in a few seconds, but after a while it slows right down and the timer jumps to 69 minutes, the pc seems to be using 100% of resources. In the end the burning process completes however.

I don't know what's wrong. can anyone help, thanks.

  wky 14:37 01 Aug 06

hmm, sorry meant to be Matshita, but there's a filter, lol.

  FelixTCat 15:25 01 Aug 06

Matshita is Panasonic, which are usually OK.

How much memory does you laptop have and how much space on your hard disk (particularly in the partition holding your Temp directory)? If you're short of either it may explain the slow-down.

What speed disks are you using? If you are using slow disks, the speed will appear faster at the beginning as you fill the write buffers and then slow down to disk speed.

Regards,

Felix

  wky 20:37 01 Aug 06

Hi, thanks for reply. My disks are 8x speed, I have 19gb of available space and roughly 700mb of ram. I don't think that should be a problem.

  wky 22:06 01 Aug 06

Hi I think I know the source of the problem, but now I need a fix. What I found out is, that in the secondary ide channel controller, the dvd-rw drive is set to PIO Mode as the device 0, but the setting is set to dma if available, and pio definately is what is slowing the computer down. I don't know why it won't use dma, does anyone have any idea? cheers.

  Fruit Bat /\0/\ 23:07 01 Aug 06

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

  wky 23:19 01 Aug 06

omg, thanks so much Fruit Bat! Your first suggestion worked a treat, this problem had been bugging me forever. Cheers mate, it's activated as multi-word dma 2 now, hope it doesn't revert!

This thread is now locked and can not be replied to.

Surface Pro 5 News - release date, UK price, features, specs

Animator Emanuele Kabu’s psychedelic video is a stunning tribute to Lisbon city

Best Mac antivirus 2017