Laptop connecting to access point instead of router

  KaldeepSingh 23:45 17 May 14
Locked

Hi. I used an old router to act as an access point using this guide click here It is working fine however one of my laptops always connects to the access point (which is on the opposite side to the house) rather than to the router which is close by. When the laptop connects to this access point it says that I have a good signal however i have a yellow triangle on the wireless connection symbol and it says 'no internet' and the internet does not work. If i switch off the access point, the laptop connects to the router and i am back online. Can anyone help me get the laptop to connect to the router even when the access point is switched on? Many thanks. Kaldeep

  Secret-Squirrel 09:50 18 May 14

The most obvious solution is to go into the section where Windows saves wireless networks and delete the entry for your access point. That should stop the laptop from connecting to it. If instead you're using a third-party wireless utility to manage networks then you'll need to look in there instead.

If you need more help with my Windows suggestion then post the version of Windows you're running.

  KaldeepSingh 16:58 18 May 14

Hi Secret-Squirrel. Thanks for you reply... I am using Windows 7... I have already restored my laptop to it's original factory setting, however this has not helped... I will try your suggestion. Should I let the laptop connect to the router before I turn the access point on?

Thank you

Kaldeep

  Secret-Squirrel 17:35 18 May 14

".......I am using Windows 7...."

Go to Control Panel -> Network & Sharing Center -> Manage Wireless Networks. Make sure your access point isn't listed there and delete all others that you no longer use or don't recognise.

Should I let the laptop connect to the router before I turn the access point on?"

Yes, if you like, although it shouldn't make any difference if the access point is no longer in the wireless networks list.

" I have already restored my laptop to it's original factory setting, however this has not helped"

Are you letting Windows 7 manage your wireless networks or are you using a different utility? If it's the latter then I have seen occasions where the software provided by Belkin and Edimax etc by default connects automatically to nearby unsecured networks. That promiscuous behaviour can turned off though. If you're using the normal Windows connection utility (like this) then that won't occur.

  KaldeepSingh 20:09 18 May 14

Hi secret squirrel... Many thanks for your reply.. Just to confirm I am using an old router as an access point... Therefore the SSID and other settings (including passwords etc) for both router and access point are the same... So I am not sure how I can ensure that the access point is not on the wireless networks list.

I am letting windows manage my wireless networks... Would it be better to use a different utility/program?

Once again thanks for your help...Kaldeep

  KaldeepSingh 20:09 18 May 14

Hi secret squirrel... Many thanks for your reply.. Just to confirm I am using an old router as an access point... Therefore the SSID and other settings (including passwords etc) for both router and access point are the same... So I am not sure how I can ensure that the access point is not on the wireless networks list.

I am letting windows manage my wireless networks... Would it be better to use a different utility/program?

Once again thanks for your help...Kaldeep

  Secret-Squirrel 21:38 18 May 14

"..... I am using an old router as an access point.......Therefore the SSID and other settings (including passwords etc) for both router and access point are the same..."

Ah, you should have said the old router was being used as an wireless extender so ignore all the advice I gave previously.

What you need to try to get your laptop to latch on to your router is to tweak its "roaming sensitivity level" or "roaming aggression" setting. Go to Control Panel -> Device Manager -> expand the "Network Adapters" section -> double-click on the laptop's wireless adapter -> "Advanced" tab. Setting the option I previously mentioned to "High" will configure the adapter to search for the best possible signal which should be the nearby router. I can't be more specific because different adapters have subtly different settings.

  KaldeepSingh 23:10 18 May 14

Sorry for the confusion, I was just going by what was on the guide I used (it said access point on there!).

What you need to try to get your laptop to latch on to your router is to tweak its "roaming sensitivity level" or "roaming aggression" setting. Go to Control Panel -> Device Manager -> expand the "Network Adapters" section -> double-click on the laptop's wireless adapter -> "Advanced" tab. Setting the option I previously mentioned to "High" will configure the adapter to search for the best possible signal which should be the nearby router. I can't be more specific because different adapters have subtly different settings.

I will try this and get back to you... Thanks for your help.

  KaldeepSingh 06:59 19 May 14

Update... Hi secret squirrel... I have tried to do your suggestion however there is no option for roaming aggression or sensitivity or anything similar... The options under the advanced tab are:

802.11b preamble, ad hoc11n, Dynamic MIMO POWER save, Network address, Receive buffers, Scan valid interval, Transmit buffers,

The wireless adapter is a AtherosAR9285. Can I adjust any of the above settings to do the same job? Many thanks

Kaldeep

  Secret-Squirrel 09:43 19 May 14

Hi Kaldeep

Firstly, apologies for being unusually sloppy by not bothering to look at your link which clearly shows how to setup a an old router as a wireless extender.

It's most odd that your adapter doesn't have any roaming options. I'd expect that with a desktop PC adapter but not a mobile device such as a laptop. Yours is quite a common problem where roaming doesn't work as expected and the computer keeps connecting to the "wrong" router. The only option there that just may improve things is the Power Save option. A Google search tells me that "This technique allows MIMO-based (802.11n) radios to downshift to less-aggressive radio configurations" so try disabling it.

At the moment I can't think of anything else to try :(

  Secret-Squirrel 13:34 19 May 14

.............updating the wireless adapter's driver may help the situation and also give you those missing roaming options. Next to the "Advanced" tab, click the "Driver" one then the "Update Driver" button. If that doesn't help then you find an updated one on your laptop manufacturer's website.

UPDATE: I've just spotted on the HP website someone saying that they were missing all the roaming options for the AtherosAR9285 and a driver update solved this and allowed them to tweak the settings to fix their problem.

Good luck.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…