LAN and wireless won't work together

  YinHoNg 13:14 05 Oct 05
Locked

Hi. I have a desktop computer and a laptop. Both are running windows xp with sp2.

The desktop connects to the internet by wirelessly connecting to the router.
The desktop and laptop are directly connected together with a rj45 cable. This forms my LAN.

I can share files easily between computers, but whenever the LAN is connected, i can't access the internet! The wireless connection still shows its connected, but webpages don't load.

As soon as i disable the LAN connection, i can immediately access the internet again!
Its almost as if the LAN connection overrides the wireless connection as the default way to connect to the internet!!

Can anybody help me?

  dantheman2 14:07 05 Oct 05

I think you will find the LAN is being used in preference and it cant cope with both. My reccomenadtion woudl have been to buy a router with switch built in too so taht you can connect both pcs in to the back of taht by cables, or connect both using wireless.

  mgmcc 14:41 05 Oct 05

If you are using a router, both PCs should be connected to the router and there should be no direct connection between them with a crossover cable.

If you must have a separate connection betweeen them, make sure you use different IP addressing from that used by the router.

For example, if your router is allocating LAN IP addresses to connected computers in the 192.168.0.xxx range, connect your network adapters with fixed IP addresses such as 10.0.0.1 and 10.0.0.2 with subnet mask 255.0.0.0 This assumes that you are not also trying to run Internet Connection Sharing over the direct connection!

  YinHoNg 14:50 05 Oct 05

hehe, all those things i was not supposed to be trying to do.... i was doing!! right, well forget it then.

Just to let you know, the reason i used a crossover cable was because my network adapters only work at a speed of 24Mbps and the crossover was working at 100MBps.... No worries.... thanks again guys.

  Chegs ® 15:02 05 Oct 05

Your trying to achieve almost the same as I was yesterday.I have my desktop connected to my router via wires,and my laptop connected to my desktop wirelessly.
click here

With the grateful assistance of Taran,I finally got my laptop online thru my desktop,but it wasn't easy.Main prob was laptop on 98se meant I was forever having to restart windows each change to laptops WiFi card,and WiFi card in desktop not sending any radio signal for more than a second until I had laptop cfg'ed right.

  Chegs ® 00:23 08 Oct 05

I found exactly the same thing happening to my system(Desktop was connected via USB,fire up the Laptop[wireless],and Desktop lost its connection,but still could swap files between desktop and laptop)On mine,I had to switch my wireless connections IP address to "Obtain IP address automatically",allow XP to reallocate its IP,then once done,reallocate an IP address manually for my WiFi card.Yours will probably be the other way round,eg:set the wired connection to "Obtain IP address automatically"let XP allocate its number,then you manually set the IP address.I have to do this everytime I restart my desktop.It should be sorted when I get hold of a Wireless router/modem though,else I to am going to get seriously peeved at my setups.

Make sure you set the IP addresses in the same ranges eg:192.168.0.* [laptop] 192.168.0.* [desktop]where * is between 0 and 254.Dependant on IP of router.

  mgmcc 08:32 08 Oct 05

<<< the reason i used a crossover cable was because my network adapters only work at a speed of 24Mbps and the crossover was working at 100MBps >>>

If the reason for a direct connection is to achieve a faster speed for File/Printer sharing, and it is interfering with your internet connection via the router, why not disable TCP/IP on the direct connection and use IPX/SPX protocol instead?


To install "IPX/SPX/NetBIOS Compatible Transport Protocol" in Windows XP, go into the Network Connections folder, right click the Local Area Connection and select Properties. In the General tab, click the Install button. In the next box, highlight Protocol and click Add. Select "NWLink IPX/SPX/NetBIOS Compatible Transport Protocol" and click OK.

  YinHoNg 15:36 08 Oct 05

Lol, you are a genius mgmcc! cheers, that has worked PERFECTLY!

Just one thing(curiosity), what is the difference between the two protocols?

  mgmcc 16:22 08 Oct 05

<<< Just one thing(curiosity), what is the difference between the two protocols? >>>

IPX/SPX is another networking protocol. However it cannot be used with the internet, which MUST use TCP/IP, and this actually makes it quite useful for avoiding conflicts with connections that are using TCP/IP.

Also, because firewalls are essentially "Internet" tools, they control TCP/IP traffic. IPX/SPX is not affected by firewalls.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…