Lan connected but now cant get internet access

  aca 19:40 26 Mar 06
Locked

2 PCs connected via LAN, connection ok and able to print over the LAN to shared printer.

(XP Pro)

On master PC have internet access ok via ADSL.

Lats few days problems with suspected Trojan. Now looks like a false positive. But have used many different scans etc. That all sorted, also system restored a few times on master PC.

havent done much to slave PC and even restoring to 3-4 days ago wont help

Now cant get access to Internet. Checked connection settings and nothing looks different or obvious.

Operating Sygate and have advanced rule allowing all traffic with slave PC.

Cant work out why suddenly wont connect to internet via IE. Just get the white screen with message generic error message. Yet ok on the master.

Baffled and in need of help and inspiration. Thanks

  mgmcc 21:14 26 Mar 06

It may be that "Internet Connection Sharing" has become disabled due to the problems that you have been experiencing. Check that ICS is still set up in the "host" PC, that its Local Area Connection has the IP address 192.168.0.1 and that the "client" PC is getting an address in the same range by DHCP from the "host".

  aca 21:36 26 Mar 06

mgmcc

cant check the client pc at moment as son sleeping in same room! On host pc. ICS looks like its ok with right IP address. However on LAN connection properties the use DNS server address preferred or automatic is blank. Should this have an address?

Cant remember whether had before.

thanks

  mgmcc 21:45 26 Mar 06

There is no DNS Server Address specified in the "host" PC.

  aca 21:50 26 Mar 06

Is it likely that problem with host or client, and worth running the network wizard again so that ICS etc sets up again?

  mgmcc 22:14 26 Mar 06

What I would try is:

1) Disable ICS on the host PC's internet connection - right click it, select Properties, then the Advanced tab. Untick the box "Allow other network users to connect through this computer's Internet connection".

2) Right click the Local Area Connection, select Properties, highlight "Internet Protocol (TCP/IP)" and click the Properties button. Select "Obtain an IP Address Automatically" and click OK back through the two boxes.

3) Reboot the computer

4) Enable ICS again on the PC's internet connection - reverse step (1).

5) Check that, by re-enabling ICS, Windows has again given the Local Area Connection the address 192.168.0.1

Now see if the "client" PC can access the internet.

  aca 07:54 27 Mar 06

mgmcc

You were right, followed the steps and now working again. Thanks for your help.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…